]1574[ Cannot attach agent

I've installed, from scratch, the latest build, using the bundled tomcat/tc and was
hoping that once the ports for the server were configured properly, I would not need
to have to do much other than start the whole lot using runAll.bat.

Well, the server starts fine, but the bundled agent does not seem to be able to
make a connection to the server and the server therefore does not see any agent.
I've checked the buildAgent.properties and the ports are what I expect them to be,
and so it the rest of the configuration.

So what gives? I keep getting this error: Runner FakeBuildAgent was not registered
I tried using the windows service version of the agent, to no avail.


Any idea anyone?

Cheers,

Bonny

4 comments
Comment actions Permalink

Hello,

Could you please send us logs from the agent?

--
Pavel Sher

"Bonny Rais" <bonnyr@optushome.com.au> wrote in message
news:15127579.1157093405661.JavaMail.itn@is.intellij.net...

I've installed, from scratch, the latest build, using the bundled
tomcat/tc and was
hoping that once the ports for the server were configured properly, I
would not need
to have to do much other than start the whole lot using runAll.bat.

>

Well, the server starts fine, but the bundled agent does not seem to be
able to
make a connection to the server and the server therefore does not see any
agent.
I've checked the buildAgent.properties and the ports are what I expect
them to be,
and so it the rest of the configuration.

>

So what gives? I keep getting this error: Runner FakeBuildAgent was not
registered
I tried using the windows service version of the agent, to no avail.

>
>

Any idea anyone?

>

Cheers,

>

Bonny



0
Comment actions Permalink

Please refer to
http://www.jetbrains.net/confluence/display/TW/HowtoDebug+problems for
information about logging.

--
Pavel Sher


"Pavel Sher" <pavel.sher@jetbrains.com> wrote in message
news:ed8ocj$u92$1@is.intellij.net...

Hello,

>

Could you please send us logs from the agent?

>

--
Pavel Sher

>

"Bonny Rais" <bonnyr@optushome.com.au> wrote in message
news:15127579.1157093405661.JavaMail.itn@is.intellij.net...

>> I've installed, from scratch, the latest build, using the bundled
>> tomcat/tc and was
>> hoping that once the ports for the server were configured properly, I
>> would not need
>> to have to do much other than start the whole lot using runAll.bat.
>>
>> Well, the server starts fine, but the bundled agent does not seem to be
>> able to
>> make a connection to the server and the server therefore does not see any
>> agent.
>> I've checked the buildAgent.properties and the ports are what I expect
>> them to be,
>> and so it the rest of the configuration.
>>
>> So what gives? I keep getting this error: Runner FakeBuildAgent was not
>> registered
>> I tried using the windows service version of the agent, to no avail.
>>
>>
>> Any idea anyone?
>>
>> Cheers,
>>
>> Bonny
>



0
Comment actions Permalink

Pavel,

Thanks for the reply.
I since found that it was Oracle TNSListener which was using the port I specified
for the agent. I've changed the port and it seems to start fine.
The problem now is that the server is not recognising the agent (I'm using the
bundled tomcat installation). The agent log is listed below.
One thing is curious: It states that it registers on the build server (last line), but the
address given is that of the agent. I don't know which server it registered with, but
it isnt with the one running on port 8111.



INFO - erver.agent.ant.AntBuildRunner - Ant Runner Extensions: jetbrains.buildServer.coverage.AntCoverageAdapter,jetbrains.buildServer.agent.ant.EchoAntExtension,jetbrains.buildServer.agent.ant.CompilerAntExtension,
INFO - gent.DotNetPropertiesExtension - Start Microsoft .NET Framework search
INFO - gent.DotNetPropertiesExtension - Found Microsoft .NET Framework v2.0.50727
INFO - gent.DotNetPropertiesExtension - Found Microsoft .NET Framework SDK v2.0
INFO - gent.DotNetPropertiesExtension - Microsoft .NET Framework search Finished
INFO - ver.agent.nant.NAntBuildRunner - Runner NAnt is not registered: NAntHome environment variable is not provided
INFO - rver.agent.impl.BuildAgentImpl - Runner NAnt was not registered
INFO - rver.agent.impl.BuildAgentImpl - Runner FakeBuildAgent was not registered
INFO - rver.agent.impl.BuildAgentImpl - Start build agent
INFO - rver.agent.impl.BuildAgentImpl - Build agent started
INFO - brains.buildServer.NetworkUtil - Found Network Interfaces:
INFO - r.agent.impl.ServerXmlRpcProxy - Registering on build server: R015922A 192.168.211.223 8911




Cheers,

Bonny

0
Comment actions Permalink

Pavel,

Sorry for the earlier post - It seems that the server does not update immediately
(I've tried refreshing, but it took some time anyway).

I'm good to go now, I think.

Cheers,

Bonny

0

Please sign in to leave a comment.