Source encoding (Ipr build runner)

Hi,

TC sets the source encoding to "UTF-8":
- in file "integrationBuild.xml":
...
<!Generic compilation settings>
]]>
...

But our sources are in ISO-8859-1. Non ascii chars, like in string "é", will
be decoded to some strange chars (which then introduces bugs in the compiled
classes). A workaround is to set the source.encoding property in the
workspace (since it is executed at start of the build process). I feel that
this is not the proper way of doing it. How should this be configured?

Thanks

Melv



1 comment
Comment actions Permalink

Hi Melv,

Melv Ng wrote:

Hi,

TC sets the source encoding to "UTF-8":
- in file "integrationBuild.xml":
...
<!Generic compilation settings>
<property name="source.encoding" value="UTF-8" />
...

But our sources are in ISO-8859-1. Non ascii chars, like in string "?", will
be decoded to some strange chars (which then introduces bugs in the compiled
classes). A workaround is to set the source.encoding property in the
workspace (since it is executed at start of the build process). I feel that
this is not the proper way of doing it. How should this be configured?


I think you should specify system property 'source.encoding'
(in build configuration's "Properties and environment variables" section.

Hope this helps,
KIR


--
Kirill Maximov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.