Using wildcards in "Artifacts Paths"

Hello,

I generate a number of build log files each of which now start with "TC-${build.number}". But, there are sometimes other files in the directory that I do not want to be artifacts associated with the build. Is there a way to tell TeamCity that the artifacts for a particular build are select files in a directory by using a wildcard? I putting the following strings in the "Artifacts Paths" field but all that does is make the agent incompatible with the build:
%build.working.dir%/build/log/%BUILD_NUMBER%.log
and
%build.working.dir%/build/log/%build.number%.log

-Dave

1 comment
Comment actions Permalink

Hello Dave,

Dave Leskovac wrote:

Hello,

I generate a number of build log files each of which now start with "TC-${build.number}". But, there are sometimes other files in the directory that I do not want to be artifacts associated with the build. Is there a way to tell TeamCity that the artifacts for a particular build are select files in a directory by using a wildcard? I putting the following strings in the "Artifacts Paths" field but all that does is make the agent incompatible with the build:
%build.working.dir%/build/log/%BUILD_NUMBER%.log
and
%build.working.dir%/build/log/%build.number%.log


Wildcards are not supported in artifact paths setting.
As a workaround I'd suggest to create a directory for your artifact files and put these log files
to this directory. And enter the name of this directory in artifact paths setting.

If you really need wildcards, please file Jira request for that.

With kind regards,
KIR



--
Kirill Maximov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.