VCS connection

Hi Guys,

I just downloaded today TeamCity for trial which is seems great product but
unfortunately I couldn't have connection to CVS working.

I have locally working cvs from eclipse or for example command line but it
doesn't work for TeamCity.

I specified in CVS settings for the projects the following fields.

Module Name, Branch Tag (Head), CVS root (ext), path to external ssh, path
to private key and when I click on "Test Connection" button I see
"elem.firstChild has no properties" message.

Also in the log for the build I see the following exception:

Could not get project sources:
java.lang.NullPointerException java.lang.NullPointerException at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection
Util.java:75) at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C
vsConnectionUtil.java:33) at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C
vsConnectionUtil.java:87) at
jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C
vsSupport.java:23)

Could you please advice what is required to make VSC connection working?

Best regards,
Juri.




6 comments
Comment actions Permalink

Hi Juri,

I think I had the same problem. It worked after inputting the default port
for ssh (is it 22?).

Melv

"Juri Artamonov" <yart@fusionone.com> wrote in message
news:ef0qul$g6j$1@is.intellij.net...

Hi Guys,

>

I just downloaded today TeamCity for trial which is seems great product
but
unfortunately I couldn't have connection to CVS working.

>

I have locally working cvs from eclipse or for example command line but it
doesn't work for TeamCity.

>

I specified in CVS settings for the projects the following fields.

>

Module Name, Branch Tag (Head), CVS root (ext), path to external ssh, path
to private key and when I click on "Test Connection" button I see
"elem.firstChild has no properties" message.

>

Also in the log for the build I see the following exception:

>

Could not get project sources:
java.lang.NullPointerException java.lang.NullPointerException at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection
Util.java:75) at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C
vsConnectionUtil.java:33) at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C
vsConnectionUtil.java:87) at
jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C
vsSupport.java:23)

>

Could you please advice what is required to make VSC connection working?

>

Best regards,
Juri.

>
>
>



0
Comment actions Permalink

Hello Juri,
NPE is fixed, as a workaround you can use default port value (22) instead of
empty.
Thanks!

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Juri Artamonov" <yart@fusionone.com> wrote in message
news:ef0qul$g6j$1@is.intellij.net...

Hi Guys,

>

I just downloaded today TeamCity for trial which is seems great product
but
unfortunately I couldn't have connection to CVS working.

>

I have locally working cvs from eclipse or for example command line but it
doesn't work for TeamCity.

>

I specified in CVS settings for the projects the following fields.

>

Module Name, Branch Tag (Head), CVS root (ext), path to external ssh, path
to private key and when I click on "Test Connection" button I see
"elem.firstChild has no properties" message.

>

Also in the log for the build I see the following exception:

>

Could not get project sources:
java.lang.NullPointerException java.lang.NullPointerException at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection
Util.java:75) at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C
vsConnectionUtil.java:33) at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C
vsConnectionUtil.java:87) at
jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C
vsSupport.java:23)

>

Could you please advice what is required to make VSC connection working?

>

Best regards,
Juri.

>
>
>



0
Comment actions Permalink

Hi Guys,

maybe I'm not clearly specified but we use ext connection type, so I have
field by field:

Module Name: src/java/app_name
Branch Name: nothing is specified here
CVS root: "ext" is selected in the combobox and in edit box
":ext:@]]>:/cvs/repository" specified

Quiet period: nothing is specified here

Ext protocol pettings
Path to external rsh: c:\Installed\ssh\ssh.exe
Path to private key file: c:\Installed\wincvs1.2\.ssh\identity
Additional parameters: nothing is specified here

Local checkout path
Local checkout path: nothing is specified here

So, I don't see here any ssh port I need to specify. Also in the logs I see
the following:

INFO - rojects.EditVcsRootsController - Error occured in
test connection
java.lang.NullPointerException
at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection
Util.java:75)
at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C
vsConnectionUtil.java:33)
at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C
vsConnectionUtil.java:87)
at
jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C
vsSupport.java:107)
at
jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.testConnection(CvsSup
port.java:28)
at
jetbrains.buildServer.controllers.admin.projects.EditVcsRootsController.doPo
st(EditVcsRootsController.java:18)
at
jetbrains.buildServer.controllers.BaseFormXmlController.doHandle(BaseFormXml
Controller.java:12)
at
jetbrains.buildServer.controllers.BaseController.handleRequestInternal(BaseC
ontroller.java:6)
at
org.springframework.web.servlet.mvc.AbstractController.handleRequest(Abstrac
tController.java:153)
at
org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(Si
mpleControllerHandlerAdapter.java:44)
at
org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServl
et.java:723)
at
org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServle
t.java:663)
at
org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkSer
vlet.java:394)
at
org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.jav
a:358)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
FilterChain.java:252)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
ain.java:173)
at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.ja
va:213)
at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja
va:178)
at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126
)
at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105
)
at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
:107)
at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processC
onnection(Http11BaseProtocol.java:664)
at
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.jav
a:527)
at
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWo
rkerThread.java:80)
at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:684)
at java.lang.Thread.run(Thread.java:595)

I have working CVS connection from command line or eclipse, could you please
advice what I need to configure in TeamCity in order to make it work?

Thanks,
Juri.


"Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
news:efb329$q9h$1@is.intellij.net...

Hello Juri,
NPE is fixed, as a workaround you can use default port value (22) instead

of

empty.
Thanks!

>

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>

"Juri Artamonov" <yart@fusionone.com> wrote in message
news:ef0qul$g6j$1@is.intellij.net...

Hi Guys,

>

I just downloaded today TeamCity for trial which is seems great product
but
unfortunately I couldn't have connection to CVS working.

>

I have locally working cvs from eclipse or for example command line but

it

doesn't work for TeamCity.

>

I specified in CVS settings for the projects the following fields.

>

Module Name, Branch Tag (Head), CVS root (ext), path to external ssh,

path

to private key and when I click on "Test Connection" button I see
"elem.firstChild has no properties" message.

>

Also in the log for the build I see the following exception:

>

Could not get project sources:
java.lang.NullPointerException java.lang.NullPointerException at

>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection

Util.java:75) at

>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C

vsConnectionUtil.java:33) at

>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C

vsConnectionUtil.java:87) at

>

jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C

vsSupport.java:23)

>

Could you please advice what is required to make VSC connection working?

>

Best regards,
Juri.

>
>
>
>

>
>


0
Comment actions Permalink

Please upgrade the server to the latest eap version. Is the problem still
reproducable?

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Juri Artamonov" <yart@fusionone.com> wrote in message
news:efr21q$bh2$1@is.intellij.net...

Hi Guys,

>

maybe I'm not clearly specified but we use ext connection type, so I have
field by field:

>

Module Name: src/java/app_name
Branch Name: nothing is specified here
CVS root: "ext" is selected in the combobox and in edit box
":ext:<username>@<hostname>:/cvs/repository" specified

>

Quiet period: nothing is specified here

>

Ext protocol pettings
Path to external rsh: c:\Installed\ssh\ssh.exe
Path to private key file: c:\Installed\wincvs1.2\.ssh\identity
Additional parameters: nothing is specified here

>

Local checkout path
Local checkout path: nothing is specified here

>

So, I don't see here any ssh port I need to specify. Also in the logs I
see
the following:

>

INFO - rojects.EditVcsRootsController - Error occured in
test connection
java.lang.NullPointerException
at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection
Util.java:75)
at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C
vsConnectionUtil.java:33)
at
com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C
vsConnectionUtil.java:87)
at
jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C
vsSupport.java:107)
at
jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.testConnection(CvsSup
port.java:28)
at
jetbrains.buildServer.controllers.admin.projects.EditVcsRootsController.doPo
st(EditVcsRootsController.java:18)
at
jetbrains.buildServer.controllers.BaseFormXmlController.doHandle(BaseFormXml
Controller.java:12)
at
jetbrains.buildServer.controllers.BaseController.handleRequestInternal(BaseC
ontroller.java:6)
at
org.springframework.web.servlet.mvc.AbstractController.handleRequest(Abstrac
tController.java:153)
at
org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(Si
mpleControllerHandlerAdapter.java:44)
at
org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServl
et.java:723)
at
org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServle
t.java:663)
at
org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkSer
vlet.java:394)
at
org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.jav
a:358)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
FilterChain.java:252)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
ain.java:173)
at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.ja
va:213)
at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja
va:178)
at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126
)
at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105
)
at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
:107)
at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processC
onnection(Http11BaseProtocol.java:664)
at
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.jav
a:527)
at
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWo
rkerThread.java:80)
at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:684)
at java.lang.Thread.run(Thread.java:595)

>

I have working CVS connection from command line or eclipse, could you
please
advice what I need to configure in TeamCity in order to make it work?

>

Thanks,
Juri.

>
>

"Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
news:efb329$q9h$1@is.intellij.net...

>> Hello Juri,
>> NPE is fixed, as a workaround you can use default port value (22) instead

of

>> empty.
>> Thanks!
>>
>> --
>> Olesya Smirnova
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>
>> "Juri Artamonov" <yart@fusionone.com> wrote in message
>> news:ef0qul$g6j$1@is.intellij.net...
>> > Hi Guys,
>> >
>> > I just downloaded today TeamCity for trial which is seems great product
>> > but
>> > unfortunately I couldn't have connection to CVS working.
>> >
>> > I have locally working cvs from eclipse or for example command line but

it

>> > doesn't work for TeamCity.
>> >
>> > I specified in CVS settings for the projects the following fields.
>> >
>> > Module Name, Branch Tag (Head), CVS root (ext), path to external ssh,

path

>> > to private key and when I click on "Test Connection" button I see
>> > "elem.firstChild has no properties" message.
>> >
>> > Also in the log for the build I see the following exception:
>> >
>> > Could not get project sources:
>> > java.lang.NullPointerException java.lang.NullPointerException at
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection

>> > Util.java:75) at
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C

>> > vsConnectionUtil.java:33) at
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C

>> > vsConnectionUtil.java:87) at
>> >

jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C

>> > vsSupport.java:23)
>> >
>> > Could you please advice what is required to make VSC connection
>> > working?
>> >
>> > Best regards,
>> > Juri.
>> >
>> >
>> >
>> >
>>
>>
>



0
Comment actions Permalink

I used the build 1615, you want me try the latest 1641?

Best regards,
Juri.

"Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
news:efr73r$rrs$1@is.intellij.net...

Please upgrade the server to the latest eap version. Is the problem still
reproducable?

>

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>

"Juri Artamonov" <yart@fusionone.com> wrote in message
news:efr21q$bh2$1@is.intellij.net...

Hi Guys,

>

maybe I'm not clearly specified but we use ext connection type, so I

have

field by field:

>

Module Name: src/java/app_name
Branch Name: nothing is specified here
CVS root: "ext" is selected in the combobox and in edit box
":ext:<username>@<hostname>:/cvs/repository" specified

>

Quiet period: nothing is specified here

>

Ext protocol pettings
Path to external rsh: c:\Installed\ssh\ssh.exe
Path to private key file: c:\Installed\wincvs1.2\.ssh\identity
Additional parameters: nothing is specified here

>

Local checkout path
Local checkout path: nothing is specified here

>

So, I don't see here any ssh port I need to specify. Also in the logs I
see
the following:

>

INFO - rojects.EditVcsRootsController - Error occured

in

test connection
java.lang.NullPointerException
at

>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection

Util.java:75)
at

>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C

vsConnectionUtil.java:33)
at

>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C

vsConnectionUtil.java:87)
at

>

jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C

vsSupport.java:107)
at

>

jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.testConnection(CvsSup

port.java:28)
at

>

jetbrains.buildServer.controllers.admin.projects.EditVcsRootsController.doPo

st(EditVcsRootsController.java:18)
at

>

jetbrains.buildServer.controllers.BaseFormXmlController.doHandle(BaseFormXml

Controller.java:12)
at

>

jetbrains.buildServer.controllers.BaseController.handleRequestInternal(BaseC

ontroller.java:6)
at

>

org.springframework.web.servlet.mvc.AbstractController.handleRequest(Abstrac

tController.java:153)
at

>

org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(Si

mpleControllerHandlerAdapter.java:44)
at

>

org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServl

et.java:723)
at

>

org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServle

t.java:663)
at

>

org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkSer

vlet.java:394)
at

>

org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.jav

a:358)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at

>

org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application

FilterChain.java:252)
at

>

org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh

ain.java:173)
at

>

org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.ja

va:213)
at

>

org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja

va:178)
at

>

org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126

)
at

>

org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105

)
at

>

org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java

:107)
at

>

org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)

at

>

org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)

at

>

org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processC

onnection(Http11BaseProtocol.java:664)
at

>

org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.jav

a:527)
at

>

org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWo

rkerThread.java:80)
at

>

org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav

a:684)
at java.lang.Thread.run(Thread.java:595)

>

I have working CVS connection from command line or eclipse, could you
please
advice what I need to configure in TeamCity in order to make it work?

>

Thanks,
Juri.

>
>

"Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
news:efb329$q9h$1@is.intellij.net...

>> Hello Juri,
>> NPE is fixed, as a workaround you can use default port value (22)

instead

of

>> empty.
>> Thanks!
>>
>> --
>> Olesya Smirnova
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>
>> "Juri Artamonov" <yart@fusionone.com> wrote in message
>> news:ef0qul$g6j$1@is.intellij.net...
>> > Hi Guys,
>> >
>> > I just downloaded today TeamCity for trial which is seems great

product

>> > but
>> > unfortunately I couldn't have connection to CVS working.
>> >
>> > I have locally working cvs from eclipse or for example command line

but

it

>> > doesn't work for TeamCity.
>> >
>> > I specified in CVS settings for the projects the following fields.
>> >
>> > Module Name, Branch Tag (Head), CVS root (ext), path to external ssh,

path

>> > to private key and when I click on "Test Connection" button I see
>> > "elem.firstChild has no properties" message.
>> >
>> > Also in the log for the build I see the following exception:
>> >
>> > Could not get project sources:
>> > java.lang.NullPointerException java.lang.NullPointerException at
>> >
>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection

>> > Util.java:75) at
>> >
>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C

>> > vsConnectionUtil.java:33) at
>> >
>

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C

>> > vsConnectionUtil.java:87) at
>> >
>

jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C

>> > vsSupport.java:23)
>> >
>> > Could you please advice what is required to make VSC connection
>> > working?
>> >
>> > Best regards,
>> > Juri.
>> >
>> >
>> >
>> >
>>
>>
>
>

>
>


0
Comment actions Permalink

Yes, please upgrade, this problem has to be fixed

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Juri Artamonov" <yart@fusionone.com> wrote in message
news:efr77h$spf$1@is.intellij.net...
>I used the build 1615, you want me try the latest 1641?
>

Best regards,
Juri.

>

"Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
news:efr73r$rrs$1@is.intellij.net...

>> Please upgrade the server to the latest eap version. Is the problem still
>> reproducable?
>>
>> --
>> Olesya Smirnova
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>
>> "Juri Artamonov" <yart@fusionone.com> wrote in message
>> news:efr21q$bh2$1@is.intellij.net...
>> > Hi Guys,
>> >
>> > maybe I'm not clearly specified but we use ext connection type, so I

have

>> > field by field:
>> >
>> > Module Name: src/java/app_name
>> > Branch Name: nothing is specified here
>> > CVS root: "ext" is selected in the combobox and in edit box
>> > ":ext:@:/cvs/repository" specified >> > >> > Quiet period: nothing is specified here >> > >> > Ext protocol pettings >> > Path to external rsh: c:\Installed\ssh\ssh.exe >> > Path to private key file: c:\Installed\wincvs1.2\.ssh\identity >> > Additional parameters: nothing is specified here >> > >> > Local checkout path >> > Local checkout path: nothing is specified here >> > >> > So, I don't see here any ssh port I need to specify. Also in the logs I >> > see >> > the following: >> > >> >]]> INFO - rojects.EditVcsRootsController - Error occured

in

>> > test connection
>> > java.lang.NullPointerException
>> > at
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection

>> > Util.java:75)
>> > at
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C

>> > vsConnectionUtil.java:33)
>> > at
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C

>> > vsConnectionUtil.java:87)
>> > at
>> >

jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C

>> > vsSupport.java:107)
>> > at
>> >

jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.testConnection(CvsSup

>> > port.java:28)
>> > at
>> >

jetbrains.buildServer.controllers.admin.projects.EditVcsRootsController.doPo

>> > st(EditVcsRootsController.java:18)
>> > at
>> >

jetbrains.buildServer.controllers.BaseFormXmlController.doHandle(BaseFormXml

>> > Controller.java:12)
>> > at
>> >

jetbrains.buildServer.controllers.BaseController.handleRequestInternal(BaseC

>> > ontroller.java:6)
>> > at
>> >

org.springframework.web.servlet.mvc.AbstractController.handleRequest(Abstrac

>> > tController.java:153)
>> > at
>> >

org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(Si

>> > mpleControllerHandlerAdapter.java:44)
>> > at
>> >

org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServl

>> > et.java:723)
>> > at
>> >

org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServle

>> > t.java:663)
>> > at
>> >

org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkSer

>> > vlet.java:394)
>> > at
>> >

org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.jav

>> > a:358)
>> > at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
>> > at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
>> > at
>> >

org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application

>> > FilterChain.java:252)
>> > at
>> >

org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh

>> > ain.java:173)
>> > at
>> >

org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.ja

>> > va:213)
>> > at
>> >

org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja

>> > va:178)
>> > at
>> >

org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126

>> > )
>> > at
>> >

org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105

>> > )
>> > at
>> >

org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java

>> > :107)
>> > at
>> >

org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)

>> > at
>> >

org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)

>> > at
>> >

org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processC

>> > onnection(Http11BaseProtocol.java:664)
>> > at
>> >

org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.jav

>> > a:527)
>> > at
>> >

org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWo

>> > rkerThread.java:80)
>> > at
>> >

org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav

>> > a:684)
>> > at java.lang.Thread.run(Thread.java:595)
>> >
>> > I have working CVS connection from command line or eclipse, could you
>> > please
>> > advice what I need to configure in TeamCity in order to make it work?
>> >
>> > Thanks,
>> > Juri.
>> >
>> >
>> > "Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
>> > news:efb329$q9h$1@is.intellij.net...
>> >> Hello Juri,
>> >> NPE is fixed, as a workaround you can use default port value (22)

instead

>> > of
>> >> empty.
>> >> Thanks!
>> >>
>> >> --
>> >> Olesya Smirnova
>> >> JetBrains, Inc
>> >> http://www.jetbrains.com
>> >> "Develop with pleasure!"
>> >>
>> >>
>> >> "Juri Artamonov" <yart@fusionone.com> wrote in message
>> >> news:ef0qul$g6j$1@is.intellij.net...
>> >> > Hi Guys,
>> >> >
>> >> > I just downloaded today TeamCity for trial which is seems great

product

>> >> > but
>> >> > unfortunately I couldn't have connection to CVS working.
>> >> >
>> >> > I have locally working cvs from eclipse or for example command line

but

>> > it
>> >> > doesn't work for TeamCity.
>> >> >
>> >> > I specified in CVS settings for the projects the following fields.
>> >> >
>> >> > Module Name, Branch Tag (Head), CVS root (ext), path to external
>> >> > ssh,
>> > path
>> >> > to private key and when I click on "Test Connection" button I see
>> >> > "elem.firstChild has no properties" message.
>> >> >
>> >> > Also in the log for the build I see the following exception:
>> >> >
>> >> > Could not get project sources:
>> >> > java.lang.NullPointerException java.lang.NullPointerException at
>> >> >
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.getPort(CvsConnection

>> >> > Util.java:75) at
>> >> >
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createSshConnection(C

>> >> > vsConnectionUtil.java:33) at
>> >> >
>> >

com.intellij.cvsSupport2.connections.CvsConnectionUtil.createExtConnection(C

>> >> > vsConnectionUtil.java:87) at
>> >> >
>> >

jetbrains.buildServer.buildTriggers.vcs.cvs.CvsSupport.createCvsConnection(C

>> >> > vsSupport.java:23)
>> >> >
>> >> > Could you please advice what is required to make VSC connection
>> >> > working?
>> >> >
>> >> > Best regards,
>> >> > Juri.
>> >> >
>> >> >
>> >> >
>> >> >
>> >>
>> >>
>> >
>> >
>>
>>
>



0

Please sign in to leave a comment.