TeamCity 1.2 EAP - SourceSafe Settings - File does not exist

Hello,

we're testing the current EAP version of TeamCity 1.2. In the sourcesafe
settings dialog you can specify the path to the vss configuration.
Sourcesafe is installed on a different server, the ini file is located at

VCONTROL\DATA\VSS\srcsafe.ini

We tried to enter
VCONTROL\DATA\VSS\ as the VSS config path but testing
the connection failed ("File does not exist"); mapping the network path to a
local drive letter (e.g.: T: and setting T:\ as the VSS config path didn't
work either (same problem). When copying the srcsafe.ini file to a local
directory on the TeamCity server (for testing purposes only) the path was
accepted without any problems.

Does the source safe connection only work if the srcsafe.ini is on the local
harddrive of the server where teamcity is installed or am I missing
something?

Regards,

Marcello


4 comments
Comment actions Permalink

Hello Marcello,

Option 'Path to VSS configuration file (srcsafe.ini):' is expecting
a full path to the VSS config file with file name itself to the SourceSafe
configuration file.
It should work if you map a local drive or if you use a network share.
(Could you please try writing '
VCONTROL\DATA\VSS\srcsafe.ini' there)

Thank you!

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello,

we're testing the current EAP version of TeamCity 1.2. In the
sourcesafe settings dialog you can specify the path to the vss
configuration. Sourcesafe is installed on a different server, the ini
file is located at
VCONTROL\DATA\VSS\srcsafe.ini

We tried to enter
VCONTROL\DATA\VSS\ as the VSS config path but
testing the connection failed ("File does not exist"); mapping the
network path to a local drive letter (e.g.: T: and setting T:\ as the
VSS config path didn't work either (same problem). When copying the
srcsafe.ini file to a local directory on the TeamCity server (for
testing purposes only) the path was accepted without any problems.

Does the source safe connection only work if the srcsafe.ini is on the
local harddrive of the server where teamcity is installed or am I
missing something?

Regards,

Marcello



0
Comment actions Permalink

Hi,

I've tried the "
VCONTROL\DATA\VSS\srcsafe.ini" as well as mapping
"'
VCONTROL\DATA\VSS" to T: and entering "T:\srcsafe.ini". It didn't
work in both cases.

Specifying C:\temp\srcsafe.ini worked.





On Thu, 14 Dec 2006 14:58:42 +0000 (UTC), Eugene Petrenko
<eugene.petrenko@jetbrains.com> wrote:

>Hello Marcello,
>

Option 'Path to VSS configuration file (srcsafe.ini):' is expecting
a full path to the VSS config file with file name itself to the SourceSafe

>configuration file.

It should work if you map a local drive or if you use a network share.
(Could you please try writing '
VCONTROL\DATA\VSS\srcsafe.ini' there)

>

Thank you!

0
Comment actions Permalink

Hello Marcello,

TeamCity tryes to communicate with VSS Share/Folder as the user, running
the server.
Could you please check if there are enough rights for that user to work
with vss.
If you are using windows service for server, please, check the settings
in the
'services' windows applet. Thank you!

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi,

I've tried the "
VCONTROL\DATA\VSS\srcsafe.ini" as well as mapping
"'
VCONTROL\DATA\VSS" to T: and entering "T:\srcsafe.ini". It didn't
work in both cases.

Specifying C:\temp\srcsafe.ini worked.

On Thu, 14 Dec 2006 14:58:42 +0000 (UTC), Eugene Petrenko
<eugene.petrenko@jetbrains.com> wrote:

>> Hello Marcello,
>>
>> Option 'Path to VSS configuration file (srcsafe.ini):' is expecting
>> a full path to the VSS config file with file name itself to the
>> SourceSafe
>> configuration file.
>> It should work if you map a local drive or if you use a network
>> share.
>> (Could you please try writing '
VCONTROL\DATA\VSS\srcsafe.ini'
>> there)
>> Thank you!
>>


0
Comment actions Permalink

Hello,

now it works. you were right, the settings of the service in the
"administrative tools" panel caused the problem. Running the windows
service with an appropriate account instead of using a local system
account solved the connection issue.

thanks a lot for your help!



On Thu, 14 Dec 2006 15:40:03 +0000 (UTC), Eugene Petrenko
<eugene.petrenko@jetbrains.com> wrote:

>Hello Marcello,
>

TeamCity tryes to communicate with VSS Share/Folder as the user, running

>the server.

Could you please check if there are enough rights for that user to work

>with vss.

If you are using windows service for server, please, check the settings

>in the

'services' windows applet. Thank you!

0

Please sign in to leave a comment.