Artifacts built with TeamCity now require Emma libraries?

Hi all,

I've been playing with TeamCity as of late and have got it building our projects and producing nice coverage reports etc.

Unfortunately, even when I turn off the code coverage reports or use a build configuration that has never had them enabled, the built artifact seems to have some references to the Emma libraries. This causes problems with deploying it in JBoss as it throws a NoClassDefFoundError looking for class com/vladium/emma/rt/RT.

Is there any way to fix this? It is almost as if it is still doing a code coverage report when building the code even when that feature is not selected.

I'm running TeamCity Version 1.1.1 (build 1730).

2 comments
Comment actions Permalink

Hello Mark,

That sounds pretty strange, because when code coverage is disabled code instrumentation is not performed (look for EMMA line in the full build log of your build - there must not be any instrumentation lines for emma).

In any case, I'd strongly recommend upgrading to TeamCity 1.2 because we've made several bugfixes regarding code coverage in this release.

If the problem persists, please file Jira request and attach teamcity.log file from your buildAgent.

Kind regards,
KIR

0
Comment actions Permalink

I discovered the problem this morning while in the process of upgrading to TeamCity 1.2.

The problem was that I had another project built by TeamCity which the main project relied on. This other project still had code coverage turned on.

So, problem solved and we've upgraded to TeamCity 1.2 anyway.

0

Please sign in to leave a comment.