Issues upgrading to 3811

Hi there,

I just tried upgrading to 3811 from the previous EAP build, and while the
settings and build history were preserved even when uninstalling the previous
version, I have a couple of issues I'm not sure how to solve:
- the new build fails to run ant builds with a 1.4 JDK (the standard version
error when attempting to run). Is teamcity using its own version of ant or
does it use the one specified by the ANT_HOME environment variable?
- after upgrading the windows tray notification client, I cannot login into
teamcity. The error message claims that the server actively refused the connection.
Logging in through the standard web interface poses no problems (and, also,
the client from 3776, although displaying the out to date warning, connected
ok to the server).

Any ideas how to fix the above?

Thx,
Andrei




4 comments
Comment actions Permalink

Hello Andrei,

Did new Windows Tray notifier asks for a server address? What address do
you use there?
If not, please have a look at HKCU/Software/Jetbrains/TeamCity/WindowsTray/Login.

Thanks!


--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi there,

I just tried upgrading to 3811 from the previous EAP build, and while
the
settings and build history were preserved even when uninstalling the
previous
version, I have a couple of issues I'm not sure how to solve:
- the new build fails to run ant builds with a 1.4 JDK (the standard
version
error when attempting to run). Is teamcity using its own version of
ant or
does it use the one specified by the ANT_HOME environment variable?
- after upgrading the windows tray notification client, I cannot login
into
teamcity. The error message claims that the server actively refused
the connection.
Logging in through the standard web interface poses no problems (and,
also,
the client from 3776, although displaying the out to date warning,
connected
ok to the server).
Any ideas how to fix the above?

Thx,
Andrei



0
Comment actions Permalink

Yes, it did, but the port I have teamcity listening on is not the default one (I have it on 8050), so it might be ignoring the address I passed in (it's http://build:8050 in my case, with a host entry for the build address).

Best,
Andrei

0
Comment actions Permalink

Hello Andrei,

Thanks!
I've created an issue at JIRA. http://www.jetbrains.net/jira/browse/TW-1957

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Yes, it did, but the port I have teamcity listening on is not the
default one (I have it on 8050), so it might be ignoring the address I
passed in (it's http://build:8050 in my case, with a host entry for
the build address).

Best,
Andrei



0
Comment actions Permalink

I've created an issue at JIRA.
http://www.jetbrains.net/jira/browse/TW-1957


And already fixed it. :)

Great, thanks a lot.
Andrei

0

Please sign in to leave a comment.