Ipr Build Runner bug in ipr file path

Hi, I have created build with ipr build runner. The problem is with "Path to .ipr file" input field. It says I should specify relative path. So I say myproject.ipr and it complains that the file does not exist. But the file exists on my disk. So I specify absolute path D:\Programme\JetBrains\TeamCity\buildAgent\work\Server\myproject\myproject.ipr and now it works and I can save the config screen.

But when I run the build it fails with the following error:

IDEA project file doesn't exist: D:\Programme\JetBrains\TeamCity\buildAgent\work\Server\myproject\D:\Programme\JetBrains\TeamCity\buildAgent\work\Server\myproject\myproject.ipr

So there is bug in the value validator for the specified field. It is critical bug, because I can't get the builder working at all.

1 comment
Comment actions Permalink

For the moment you need to have your ipr file checked in to a version
control system. There is an outstanding request to allow more
flexibility on this


Please sign in to leave a comment.