Team city 2.1 evaluation, package javax.servlet does not exist

Hello - I'm evaluating Teamcity for my company. We use IDEA for our development and we dont maintain any ANT scripts so using Teamcity with the IPR build runner seems to be the best solution for us.

Unfortunately there are problems - some I have solved, but now I'm really stuck. I cant find a clue on how I should tell the Build Runner where it finds the Tomcat library files. When TC reads the IPR file it detects the "Project Global Libraries" - and then I can type their paths into buildAgent.properties - but Tomcat 5 belongs below "Application Server Libraries" in IDEA and is never detected by IPR runner, it seems.

What am I missing? I've tried to read the documentation, but I can't find anything helpful.

Thanks!


-- Update --
This was an IDEA problem. I had set up Tomcat 5 under Global Resources -> Application Server libraries. By a coincidence I detected that these files didn't come into the classpath (IDEA used j2ee.jar for the servlet stuff). So I manually sat up the tomcat libs under Project Libraries. Then I redid the Teamcity configurations, and now it works fine!

Message was edited by:
eigil

1 comment

Hello,

Actually, "Tomcat 5" should be detected and displayed under Project Global Libraries in IPR runner settings. If it is not, please submit a bug report to our tracker: http://www.jetbrains.net/jira If it possible, please attach iml referring to the library to the issue.

However, there is a known issue in the 2.1 release of TeamCity with not handling global project libraries with spaces well (I hope it will be fixed soon in a minor update). Can you please try to rename Tomcat 5 library to something without spaces (e.g. Tomcat.5), resave IPR runner settings form and try to run the build?

--
Best regards,

Yegor Yarko
Quality Assurance Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.