Visual Studio 2008 (Orcas) Solution launcher

I installed last EAP build (5644) but not found there way to build vs2008 solutions - do you plan to implement it? at least .net2.0 support.

4 comments

Hello Pavel,

Please try as a workaround to set up environment variable in
the build settings on the Web (tab 6. Properties and environment variables)
set 'MSBuild' variable (note, case is sensitive) to the value '%system.DotNetFramework3.5_Path%'

I've created an issue in out Jira for the problem. You may watch it at
http://www.jetbrains.net/jira/browse/TW-3612

Thanks!

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I installed last EAP build (5644) but not found there way to build
vs2008 solutions - do you plan to implement it? at least .net2.0
support.



0

this workaround works for me, thanks

0

Also mentioned some problems in patching projects for testing. Not sure that this problem related to solution launcher, but think so.

In most cases test run and finish successfully with error messages in logs, and sometimes tests doesn't start or finish. Errors looks simple:
[Target "NUnit_TeamCity_generated_262e63270a5b41c2a49084a06d725cc5" in project "Test.sln.teamcity.patch.proj"] NUnit Error: Could not load file or assembly 'nunit.framework, Version=2.4.3.0, Culture=neutral, PublicKeyToken=96d09a1eb7f44a77' or one of its dependencies.
But we use nunit 2.4 in this project alongside with others (developed with VS2005) - with no problems.

0

Hello Pavel,

How much build agents is used?
Does that failure allways happends on same agent? If so, could you please
check
if NUnit.Framework.dll is installed in GAC/accessible/placed near test dll
on the agent and
the same on the other agent where the build is OK.

Actually it is interesting if there are some differences in the configuration
of agents.


BTW. I have implemented solution 2008 runner. It will be available in the
next EAP.

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Also mentioned some problems in patching projects for testing. Not
sure that this problem related to solution launcher, but think so.

In most cases test run and finish successfully with error messages in
logs, and sometimes tests doesn't start or finish. Errors looks
simple:
[Target "NUnit_TeamCity_generated_262e63270a5b41c2a49084a06d725cc5"
in project "Test.sln.teamcity.patch.proj"] NUnit Error: Could not load
file or assembly 'nunit.framework, Version=2.4.3.0, Culture=neutral,
PublicKeyToken=96d09a1eb7f44a77' or one of its dependencies.
But we use nunit 2.4 in this project alongside with others (developed
with VS2005) - with no problems.



0

Please sign in to leave a comment.