Help - TeamCity doesn't get source from TFS

I'm using TFS with VS2008. I've set the VCS checkout mode to automatically on the server and left the checkout dir blank (default). I've correctly set the TFS settings and tested the connection.
When running the build the log reports:
: Checking for changes
: Building in C:\TeamCity\buildAgent\work\cea690545cb26bd4
: Clearing temporary directory: C:\TeamCity\buildAgent\temp\buildTmp
: Getting project sources
however, the 'cea690545cb26bd4' dir is never populated and the build times out.

I've noticed that a new TFS Workspace has not been created for use by TeamCity. Is this correct?

Please advise asap - I have a deadline to get TeamCity working by the end of the day to demo to the dept otherwise we go back to CruiseControl.

2 comments

I should probably add that the TFS server is on a domain but TeamCity is not. The TFS settings are using a domain user account.

0

Hello,

What user name is used as login? Please try using DOMAIN/UserName

What is shown if click 'test connection'?

Is that possible to work with TFS from that computer using Team Explorer?

Thanks!
--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I should probably add that the TFS server is on a domain but TeamCity
is not. The TFS settings are using a domain user account.



0

Please sign in to leave a comment.