Remember Me Check box not working

Hi

We are running Teamcity 3.1 (6760) and having issues with the "Remember Me" check box on the login screen. It doesn't remember me very well :)

For example, if I restart the server, which I have to do every night to back up (based upon Teamcity recommendation) the remember me fails to remember me across restarts. I have also noticed times when it just decided to not work.

There are two "RememberMe" cookies in my browser

One for fully qualified domain name and one for simple name. The expiry is set to 11/04/08 05:09:55 PM so this should be fine.

Any ideas on how to make this better.

BTW we are using the LDAP module for username/password.

Thanks
Colin

6 comments

Actually, just tested some more.....

I closed my browser and the cooke for the fully qualified domain name (the url I am using) was deleted !

So when I re-opened it prompted me to login again.

Colin

0

Hello,

Indeed if you log into the TeamCity using short URL then when you will use long URL cookie won't be sent by browser and TeamCity will show you login page. Then after the successful login you'll get new "remember me" cookie and TeamCity will forget about old cookie. Next time when you try to use TeamCity by short URL you'll get login page again because browser will try to use old cookie which is already deleted by TeamCity. This is a known problem and we are going to address it in the next version of TeamCity.

--
Pavel Sher

0

I did some more testing and here is what I found.

I removed the short url cookie so that would not come into play.

I start with no cookies
Log into Teamcity with checkbox Remember Me checked (I checked the cookie and it is there)
Close Browser
Open Browser and go to Teamcity
go to login page (I checked and the RememberMe Cookie is gone)

Is there any way to fix this.

Colin

0

What browser do you use? Some users reported that remember me is not working if host name contains '_', is this your case?

--
Pavel Sher

0

I tested on...
Firefox on Linux
IE on Windows

I think it may have something to do with the LDAP stuff we have configured.

All our accounts have ionaglobal\ as the username BUT in the login box we only enter (we have the ldap-config file fixed so it always prefixes the ionaglobal\ The cookie contains the full ionaglobal\]]> as well so maybe something is getting messed up.

What do you think

BTW, No "_" in our name

Colin

Edited by: Colin Jackman on Apr 3, 2008 12:25 PM

0

Probably you are right. It looks like it is really related to LDAP authentication. It is possible that browser does not like such value for a cookie. Actually in 3.1.1 we've made a fix which modifies usernames of LDAP users: we removed prefix from usernames. I would suggest you to try to upgrade to 3.1.1 (of course you need to backup your data first) and check whether the bug is fixed.

--
Pavel Sher

0

Please sign in to leave a comment.