How to increase server upload/request limit, or what's wrong?

Hello,

I use TeamCity Professional 3.1.1 (and 3.0.1 earlier) and I want to build some library on Darwin (MacOsX), I use my own build system and "Command Line" agent - it's ok. All work fine, but artifact publishing: when buildAgent trying to publish (deploy) compiled library on server it's got 413 error response and write log like this:
"Failed to publish artifact: /Applications/buildAgent/<...>, server status: 413 (Request Entity Too Large)".
Unfortunately, I can't reduce size of compiled library (it's universal binary compiled wxWidgets core library with debug information, it minimal size is about 95 Mb).
I don't know how to right configure Apache/Tomcat, please, help me. Where I may change maximum entity size for TeamCity's http server? Or may be I doing something wrong?

7 comments
Comment actions Permalink

Take a look at server configuration page, you can specify maximum uploaded artifact size there.

--
Pavel Sher

0
Comment actions Permalink

No, it's error arise independed from value of this options on server config page (now "Maximum artifact size" value -1/unlimited).
Also no any messages in server's log related with this error (only messages in agent's log with reflection in build log). I think this not a TeamCity self reply, but tomcat server.

0
Comment actions Permalink

Is it possible to capture HTTP traffic between agent and server? I see two possible reasons: either HTTP request is improperly formed or there is some strange behaviour in Tomcat. We did not experience such problems, some of the artifacts on our own server have size about 300Mb.

--
Pavel Sher

0
Comment actions Permalink

I found reason of problem (and solution).
Thank you Pavel you question help me turn my mind in to right direction.
It' was error from our gateway, all traffic from agent went through Internet gateway passing over local network.

0
Comment actions Permalink

I'm having this same issue after upgrading TeamCity to 2019.1.  File size is < max upload size.  

0
Comment actions Permalink

Hi,

 

if you are having the same issue, the statements from Pavel Sher are still valid, if you are using the default provided tomcat. Please check that the intermediate servers are not altering the traffic, proxy servers or other sort of gateways are the most common culprits. If you aren't using the provided tomcat installation you will need to check with that on your own.

 

If the file size is very close on max upload size, even if still smaller, consider increasing it anyway.

0
Comment actions Permalink

In my case, I found that my reverse proxy server (nginx) settings were too small for the "client_max_body_size" setting.  I updated that to a large number.

0

Please sign in to leave a comment.