Build Agents not reconnecting after service restart.

I am unable to get Agents to reconnect after a restart of the TeamCity service. We have 3 agents, one of which is on the box with the service itself. All three are listed as 'disconnected', with inactivity reason as 'server shutdown'.

First, how can I verify that the agents are running as expected? Telnet, etc?
Second, I don't see any think other than service.stop and service.start for the agents. Is there any other way to 'reset' them?

Yesterday, I stopped the TeamCity Service to perform this update.

http://www.jetbrains.net/tracker/issue/TW-4885

After the update, we restarted TeamCity, and all three of our agents reconnected within minutes. I had some strange behavior with that update (trying to get RowTest working with NUnit 2.4.7), so I rolled back the update I performed( I had a backup of webapps/root/update/plugins/dotnetplugin.zip and restored it). I then restarted the service, and unlike the first time, none of the agents will reconnect. I have given it a good 20 minutes without touching anything, and they still did not reconnect. After that, I tried stopping and starting the service, as well as one of the agents. No luck..

Any suggestions?

Thanks,


.. update May 16, 2008 10:31 AM

I have also tried uninstalling and reinstalling the agent running on the same box as the server. Still, all three agents remain 'disconnected'.

Edited by: Roger Guess on May 16, 2008 10:31 AM

4 comments

Fixed...

Essentially, the updates to the agents were failing because of the dotnetPlugin.zip file I coppied to a backup (dotnetPlugin-20080515bu.zip) before I updated it. When this extra file was removed, the agents successfully updated and registered with the server.

Troubleshooting..
- the teamcity-server.log showed hundreds of attempts to 'upgrade' agents.
- teamcity-agent.log showed 'upgrade failed, restart build agent' and 'shutdown agent start' after attempting to copy that extra zip file.

Thanks Yegor for your help.

0

Thanks a lot, this workaround solved our issues as well when trying to upgrade.

0

Thanks a lot, this workaround solved our issues as well when trying to upgrade.

0

After following the procedure here I'm not able to run RowTest tests yet, how did you manage to do it?

0

Please sign in to leave a comment.