How to configure missing maven libraries

I'm looking for a way to resolve error messages for inspection build (maven project)

"Please configure library 'xxx' in module 'a.b.c'"

The library in hand is not in official maven repository.

I've found two candidates for local maven cache that TeamCity service may use: c:\.m2 and c:\window32\system\config\systemprofile\.m2. Populating missing library there does not help.

Is there a way to fix that?

4 comments

Hello

This message seems not relate to a missing library in the repository, rather
it more likely indicates a problem in the corresponding pom.xml.
We're not using maven actively so I can't tell what the problem exactly are
you facing.

You should consider contacting Maven's support.

Thank you.

Please configure library 'xxx' in module 'a.b.c'

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

I am using TeamCity Professional Version 3.1.1 on Windows desktop and hit the similar issue:

1) javax.jms:jms:jar:1.1
Try downloading the file manually from:
http://java.sun.com/products/jms/docs.html

similar error for following missing artifacts:
com.sun.jdmk:jmxtools:jar:1.2.1
com.sun.jmx:jmxri:jar:1.2.1



I was able to build the package using mvn command line (mvn clean package) but not through TeamCity even though the required jars were present in my local repository (C:\Documents and Settings\]]>\.m2\repository).

After analyzing this further i found that TeamCity is refering to a different local repository (C:\windows\system32\config\systemprofile\.m2\repository). I looked at all the configuration files and Admin sections but could not find a place to change it.

Solution:
Specify the location of local repository in settings.xml present in /conf directory. On my machine it looks like: c:/docume~1/rnagar/.m2/repository]]>

This resolved the issue

Hope this works for you as well.

Rakesh Nagar

0

Hi,

Interesting, may be the problem is that TeamCity build agent is running under system user, who has profile under C:\windows\system32\config\systemprofile ?
The solution may be to change user account build agent service is running under.

Regards,
KIR

0

You are right Kirill.

It was because of the TC was running as system user. Have fixed it and its runing fine.

Details are mentioned here

Thanks
Rakesh

0

Please sign in to leave a comment.