Are RSS Feeds Enabled in Professional Edition?

I'm trying to impress the boss with how many ways TeamCity keeps us updated and I want to have the Build RSS Feed on my Visual Studio Start Page (instead of the Marketing feeds that are there by default).

I think I've set everything up appropriately.. What am I missing?

Hoping it's not the Enterprise Edition - Jon

5 comments

Jon,

Professional version in not limited in respect to RSS. (There are only several limitations in Professional vs. Enterprise).

What URL do you use for the feed? Can you see the feed from your browser? Can you see the feed from the browser, when you are not logged in into TeamCity?

Most probably, there is an authentication issue.

The most easy (but a bit insecure) way to allow viewing a feed is to allow status widget for the build configuration to make it freely accessible in RSS feeds.

Another option is to enable Guest user.

Note that the RSS feed URL is generated depending on the settings, so you should reload the page and copy the URL after settings changing.

If you used direct links to the feed form the build configuration pages, you can also try the feed generator available from the "Syndication Feed" section of "My Settings & Tools" page.

Hope, this helps.

--
Best regards,

Yegor Yarko
Project Manager
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Hey Yegor,

I can see the feed using a regular browser. The status widget is allowed. The guest user is enabled.

I paste the same RSS as is shown in the text box by: "Copy and paste the URL into your feed reader" into the Visual Studio's
Tools\Options\Environment\Startup\Start Page News Channel text box.

VS returns "The current news channel might not be valid or your Internet connection might be unavailable..."

It's not unavailable. I have exactly the same results in both 05 and 08..

Thanks in advance for any extra information you can provide - Jon

0

Jonathan,

If you can see the feed in a usual browser (without previous login into TeamCity) and cannot see it in your IDE, the problem is probably in the way IDE retrieves the web content.

There might be a proxy, or firewall involved that block access.

--
Best regards,

Yegor Yarko
Project Manager
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

VS2008 seems to understand RSS only. By default TeamCity send atom feed. To change that, please do the following:

open /config/default-feed-item-template.ftl copy it replace with ]]>
save it in the same folder with name feed-item-template.ftl
wait 5 min
try setting the same feed url to VS overview page.

Actually, you may change the template to suites your needs.

0

Thanks Eugene, I'm trying it now.

I wonder why my watch thingee isn't mailing me when you guys respond...?

0

Please sign in to leave a comment.