Problem create vcs root: Authentication required for 'svn+ssh://SvnServer'

Hi, I am new to TeamCity. When attempting to create a new vcs root, I encountered the "svn: Authentication required for 'svn+ssh://SvnServer'" when testing connection in Administration > Create Build Configuration > New VCS Root screen. Please help.

I should mention that svn works outside of TeamCity. The following line in svn config file might matter:


ssh = sexec -pk=1 -user=ccnet64bit

Here is the relevant info I put into the teamcity New VCS Root screen:

SVN Connection Settings
URL: svn+ssh://SvnServer/repos/trunk
User name: xxx
Password: xxx
Default config directory: Use default config directory

Externals support: Checkout externals and load external changes

SSH settings
Private key file path: xxx
Private key file password: xxx
SSH port: 22

7 comments

Hello,

Could you please collect SVN and VCS logs with enabled debug information.
Please use links below to view how to enable the logs:

http://www.jetbrains.net/confluence/display/TCD3/Reporting+Issues#ReportingIssues-vcs

We will need teamcity-svn.log and teamcity-vcs.log files.

Thanks!
KIR

0

Thanks for looking into the issue.

Attached is the vcs log. I did turn on the svn log option in teamcity-server-log4j.xml and restart the server in an attempt to generate the svn log. However, this did not produce the log file. Perhaps the issue I encountered here occurs before the svn log creation?

Xiaohui



Attachment(s):
teamcity-vcs.log
0

Hi,

The svn log should be created even if there are no svn operations.
Please make sure the following lines exist in your teamcity-server-log4j.xml config file:

]]>
<param name="file" value="$teamcity-svn.log"/>

and ]]>


Kind regards,
KIR

0

Followed your instruction and did get svn log file created. However, during the several "test connection" trials nothing got written into the svn log. By now the log file is still of size 0.

0

What version of TeamCity are you using? What is the build number?
Please try latest build 3.1.2 - build 6881 . There were some fixes in SVN support.

0

I am testing TeamCity Professional Version 3.1.2 (build 6881).

0

That's strange. Could you please file an issue into our tracker at http://jetbrains.net/tracker and
provide all the details about your setup.

Thanks!
KIR

0

Please sign in to leave a comment.