NAnt home setting in the NAnt Runner

Hi,

as part of our build process we check out the tools we use for the build, e.g. NAnt. The problem I've run into is that the 'NAnt home' setting in the NAnt Runner is not relative to the checkout directory, rather it is relative to the agent's working directory. Is there a variable I can use when specifying the path for NAnt that would be replaced with the checkout directory?

Thanks,

Damien

Edited by: Damien Jones on Sep 5, 2008 9:30 PM

4 comments

not that it solves your problem directly - but as an alternative..

we put the tools on the build agents when we install the agents, and simply use variables in the agent conf files to define where nant is for that machine. Then we reference that variable in the build config. This way no matter where nant is on each agent machine, the build works. The agent tells us where nant is.

0

We're looking at VMs for our agent machines in which case this would be a reasonable option. As long as we only have to make changes in one place I'll be happy, otherwise we are bound to miss one at some point.

0

I have added an issue to the tracked for that problem at http://www.jetbrains.net/tracker/issue/TW-5782
Please watch/vote for it.

Please try using %system.teamcity.build.workingDir% as a reference to build working directory.
Thanks!

0

Could you please attach full build log of the build where it has failed to locate nant?
What was the settings for NAnt home?
What is relative path to nant checkout folder.

Thanks!

0

Please sign in to leave a comment.