Maven model inspection

I have a TeamCity build configuration to perform code inspection.

When I execute the build, it reports lots of errors against the "Maven Model Inspection", e.g.:

25: Cannot resolve symbol org.apache.maven.plugins
26: Cannot resolve symbol maven-compiler-plugin
33: Cannot resolve symbol org.codehaus.mojo
34: Cannot resolve symbol cobertura-maven-plugin
35: Cannot resolve symbol 2.2
52: Cannot resolve symbol org.codehaus.mojo
53: Cannot resolve symbol cobertura-maven-plugin
54: Cannot resolve symbol 2.2
68: Cannot resolve symbol org.springframework
69: Cannot resolve symbol spring
70: Cannot resolve symbol ${spring.framework.version}
73: Cannot resolve symbol org.hibernate
74: Cannot resolve symbol hibernate
75: Cannot resolve symbol ${hibernate.version}

These errors do not appear when performing inspections in IDEA, so there seems to be a problem relating to the Maven model inspection when executed from TeamCity.

Is there some extra configuration that I need to do?

2 comments
Comment actions Permalink

Does anyone have any ideas on this? It is still a problem. Note that this is using TeamCity 3.1.2 running on RHEL 5.

Is it because TeamCity needs to update its Maven indices, in the way that IntelliJ IDEA needs to? If so, how do I do that?

0
Comment actions Permalink

Kevin,
We are working on this issue and, hopefully, it will be fixed in on of the next TeamCity releases.
You may temporarily disable "Maven Model Inspection" in the build.

0

Please sign in to leave a comment.