Problem with Visual Studio add-on

Greetings!

I'm currently facing another problem with Teamcity.
I've installed VS addon and try it use it from my VS 2005.
But when I'm tryin' to run personal build - I fail.
Changed files tree is empty - no matter how changed are real project files - it remains empty. :(
Where to dig? Please help me - I have no error messages, progress bar reports that it has collected all changes and found none. :(

Edited by: Roger Taylor on Oct 9, 2008 4:11 PM

17 comments
Comment actions Permalink

In case you use svn, please open tab 'Subversion' and check you have set path to Subversion command line client (CLI)

Thanks!

0
Comment actions Permalink

Thanks Eugene!

I did not understand what do u mean. I have Tortoise SVN client and also I've installed 1.4 from subversion.tigris.org. So what should I use. And BTW - how teamcity add-on works.

Still have no idea how to fix it...

0
Comment actions Permalink

Sorry,
In remote run dialog, please select Subversion tab.
There you will have to provide path to svn commandline tool aka svn.exe

You need to have svn commandline client of the same version, like 1.4 or 1.5, as Tortoise SVN.

Thanks!

0
Comment actions Permalink

Eugene - no luck :(

Selected path to svn.exe and I'm still there - Tortoise shows a list of changes and add-on does not.
What to do?

Thanks for your support!

0
Comment actions Permalink

What version of TotroiseSVN and SVN cli do you have?

Could you please try calling svn.exe in you project svn checkout folder:
svn.exe status .

and please try that:
svn.exe status . --xml

Thanks!

0
Comment actions Permalink

That what I get running your command -
svn: This client is too old to work with working copy '.'; please get a newer Su
bversion client

Lemme explain once again - I have SVN on my server. And I have Tortoise locally and also I've installed 1.5 svn locally for the purposes of team-city integration .
What's wrong with mine config?

0
Comment actions Permalink

What version of TortoiseSVN do you have?

Please call svn.exe --version

Thanks!

0
Comment actions Permalink

Eugene - svn, version 1.4.6 (r28521)!

0
Comment actions Permalink

And the version of Tortoise SVN is... I mean windows SVN client here.

0
Comment actions Permalink

TortoiseSVN 1.5.0, Build 13316 - 32 Bit , 2008/06/21 07:55:29

BTW - on previous version I had no problems (as far as I remember - I've tested teamcity in march-april)

Edited by: Roger Taylor on Oct 10, 2008 1:19 PM

0
Comment actions Permalink

The problem is in your outdated svn.exe client. So your UI client is 1.5 and that means your checkout directory contains .svn folders with version 1.5, your commandline client is 1.4 and it does not compatible with 1.5 working copy format.

That is svn.exe what is used from VS addon. Please upgrade svn.exe to 1.5 version.

Subversion used to upgrade your working copy format silently when you run newer version of in to checkout folder.

Thanks!

0
Comment actions Permalink

THANKS!
Could u please add it to your bug-feature list?
Just to say it loud - kinda "Your svn.exe version doesn't correspond your tortoise.exe version" - maybe I'm asking too much....nevermind :)

0
Comment actions Permalink

Sorry,
What version of TeamCity was that?

0
Comment actions Permalink

TeamCity Professional Version 3.1 (build 6760)

0
Comment actions Permalink

Eugene - still no luck

I've updated my local svn
Now it's
svn, version 1.5.2 (r32768)
compiled Aug 29 2008, 18:45:49

But when I try to use it from add-on menu I get non-informative messages (see screenshot)

Help me please

PS

I have both Tortoise and local SVN 1.5.2 - so seems like your recommendation do not work here

Edited by: Roger Taylor on Oct 13, 2008 10:35 AM



Attachment(s):
Add_on_trouble.rar
0
Comment actions Permalink

Thanks. Please sorry, I should have noticed that you are still using 3.1. Please try upgrading to 3.1.2. TeamCity vs-addin supports SVN 1.5 only starting from 3.1.2.

As workaround please try to revert to svn version 1.4.* both for svn.exe and Tortoise SVN. (Please note, it would require to checkout all files from svn again (because or .svn data version change)

0
Comment actions Permalink

Thanks - finally solved this one.
Now I have 1.4.4 Tortoise and 1.4.6 Subversion locally =).
But I immediately run into another kind of problems - with Russian log messages. See my another thread =)

0

Please sign in to leave a comment.