NUnit failure when no tests failed

I am running the nunitlauncher as part of an msbuild file. All of the tests are passing and it says success, yet I receive a failure from nunitlauncher. Here is part of the build log.

: [Target "BuildProjects" in project "build.msbuild.teamcity.patch.tcprojx"] Tests run: 218, Failures: 0, Not run: 0, Time: 10.188 seconds
: [Target "BuildProjects" in project "build.msbuild.teamcity.patch.tcprojx"] 1 Test(s) failed.
: [Target "BuildProjects" in project "build.msbuild.teamcity.patch.tcprojx"] C:\CIBuild\Source\BuildUtils\build.msbuild(11, 5): error MSB6006: "C:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe" exited with code 1.

Here is part of my msbuild.
]]>

Any thoughts on what might be causing the problem?

8 comments

What version of TeamCity is that?

Please enable logging from NUnit runner:

1. Open /plugins/dotnetplugin/bin folder 2. Open teamcity-log4net.xml with any text editor, for example, Microsoft Notepad 3. Make backup copy 4. Set logging level to DEBUG. To do so, replace the original lines: with the following new ones: ]]>

After debug log is created, please do not forget to rollback the change.
Note: The change in teamcity-log4net.xml will be removed on build agent autoupgrade

Please attach the build log from new build. Make sure the build was started on the patched build agent.


Thanks!

0

I am using TeamCity Professional version 3.1.2.

I have attached the build log.



Attachment(s):
Newdea_Business_Testing_37.log
0

NUnit test runner returned failure. We had fixed that issue in 4.0 builds. Is that possible for you to try 4.0EAP? Could you please try running tests with NUnit runner? Please check there is no Fixture Setup/Fixture TearDown failures inside.

I can send you a patch for 3.0 if needed.

Thanks!

0

I upgraded to 4.0 earlier this week and noticed that it fixed the problem. Sorry that I forgot to update this post with the new information. I am very happy with the results from 4.0.

0

I have similar error.

:\TeamCity\buildAgent\bin\..\plugins\dotnetPlugin\bin\JetBrains.BuildServer.MsBuildBootstrap.exe @xml C:\SmartValBaseline\msbuild.xml.teamcity.bootstrap.properties
TeamCity MSBuild bootstrap v3.1 Copyright (C) JetBrains s.r.o. by Eugene Petrenko
Start MSBuild...
'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\MSBuild.exe' '@"C:\SmartValBaseline\msbuild.xml.teamcity.msbuild.tcargs"'
working dir = 'C:\SmartValBaseline'
Microsoft (R) Build Engine Version 2.0.50727.1433

Copyright (C) Microsoft Corporation 2005. All rights reserved.

Build started 10/17/2008 2:52:36 PM.
__________________________________________________
Project "C:\Baseline\msbuild.xml.teamcity.patch.tcprojx" (default targets):

Target XDPA BASELINE:
C:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe "@@" C:\TeamCity\buildAgent\temp\buildTmp\tmp1E6.tmp
C:\Baseline\msbuild.xml(8,6): error MSB6006: "C:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe" exited with code 1.
Done building target "BASELINE" in project "msbuild.xml.teamcity.patch.tcprojx" -- FAILED.

Done building project "msbuild.xml.teamcity.patch.tcprojx" -- FAILED.

Build FAILED.
C:\Baseline\msbuild.xml(8,6): error MSB6006: "C:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe" exited with code 1.
0 Warning(s)
1 Error(s)

Time Elapsed 00:00:26.78
: Process exit code: 1

Tried to install 4.0 on my machine. However, I couldn't get the build agent to connect. Any idea? How can I apply the patch?

0

Please check build agent in authorized on the server. Please note, you have to have the right to authorize agents in case enterprise TeamCity is used.
Check build agent port is not firewalled.

Thank!

0

I have no problem to authorize and unauthorize a build agent with TeamCity 3.1.2. I could authorize a build agent on 4.0 too. However, the status alway showed "disconnected" and the only discounnected build agent can be authorized or unauthorized. Any idea?

0

Please enable logging on build agent and please send me those logs.
please see http://www.jetbrains.net/confluence/x/X48 for detail

0

Please sign in to leave a comment.