Publishing small artifacts takes a lot of time

Hi

During analyzing time spent by our builds we found strange thing.
Publishing 31 files each near 10Kb in average, spent 3 minutes.
Here is list of file sizes.
4.43Kb, 18.70Kb, 79.26Kb, 459b, 10.10Kb, 2.15Kb, 1.76Kb, 769b, 1.4Kb, 1.31Kb, 1.6Kb, 1.6Kb, 2.56Kb, 313b, 4.88Kb, 5.48Kb, 1.12Kb, 1.18Kb, 165b, 129b, 1.12Kb, 2.95Kb, 165b, 6.5Kb, 4.48Kb, 1.11Kb, 817b, 165b, 105b, 1,019b, 2.54Kb

Here is search rules
\[21:32:52\]: Publishing artifacts (3m:25s)
\[21:32:52\]: \[Publishing artifacts\] Paths to publish: \[Folder1/Folder2/Folder3/. => /, , Folder1/Folder2/Folder3/Folder4/. => /, teamcity-info.xml\]
\[21:32:52\]: \[Publishing artifacts\] Publishing artifacts 'Folder1/Folder2l/Folder3/.' to /
\[21:35:44\]: \[Publishing artifacts\] Publishing artifacts 'Folder1/Folder2/Folder3/Folder4/.' to /
\[21:36:19\]: Build finished

Is it normal, or it can be fixed by some build setting?

--
Best regards,

Alexander Shishenin
QA Lead at Client Team
Moscow Development Studio
Nival Online
http://www.nivalonline.com

2 comments
Comment actions Permalink

Alexander,

This looks like a performance problem for artifacts publishing code. Most likely, the algorithm of artifact search on the disk is not
optimal. Could you please file the issue to our tracker?

Thanks,
KIR

0
Comment actions Permalink



--
Best regards,

Alexander Shishenin
QA Lead at Client Team
Moscow Development Studio
Nival Online
http://www.nivalonline.com

0

Please sign in to leave a comment.