Problem with VCS triggers using starteam views.

We just upgraded to 3.2.1 and we are running into the following issue: We use Starteam for source control.

If we use a NON root view as the URL for VCS settings, any check-ins made to starteam is not geting picked up by trigger.

example that DOES NOT work:

"Project 1"(root project) has a view "View AA". "View AA" has another view "View BB" derived from it.
so, it looks like:
"Project 1" -> "View AA" -> "View BB"

URL for VCS trigger looks like:
starteam://host:49201/Project 1/View AA/View BB/Source, where source is a root folder in view "View BB"
THIS DOES NOT WORK. Am I missing a syntax in here??

example that WORKS:
For example: we have a project "Project 1"(root project)
so, it looks like:
"Project 1"

URL for VCS trigger looks like:
starteam://host:49201/Project 1/Project 1/Source, where source is a root folder in view "Project 1"
THIS WORKS.

Any help is appreciated.

We havent changed anything when we upgraded to 3.2.1. All the projects configured from root is working(as in second example). Anything else that resembles the first example is broke royally.

Edited by: rajnish on Sep 10, 2008 12:00 AM

Edited by: rajnish on Sep 10, 2008 7:09 AM

18 comments

Hello rajnish,

This is a known problem. See http://jetbrains.net/tracker/issue/TW-5651
It will be fixed in the next EAP.

Thank you for reporting.

We just upgraded to 3.2.1 and we are running into the following issue:
We use Starteam for source control.

If we use a NON root view as the URL, TeamCity, any check-ins made to
starteam is not geting picked up by trigger.

example that DOES NOT work:

"Project 1"(root project) has a view "View AA". "View AA" has another
view "View BB" derived from it.
so, it looks like:
"Project 1"
"View AA"
"View BB"
URL for VCS trigger looks like:

starteam://host:49201/Project 1/View AA/View BB/Source, where source
is a root folder in view "View BB"

THIS DOES NOT WORK. Am I missing a syntax in here??

example that WORKS:
For example: we have a project "Project 1"(root project)
so, it looks like:
"Project 1"
URL for VCS trigger looks like:
starteam://host:49201/Project 1/Project 1/Source, where source is a
root folder in view "Project 1"
THIS WORKS.
Any help is appreciated.

We havent changed anything when we upgraded to 3.2.1. All the
projects configured from root is working(as in second example).
Anything else that resembles the first example is broke royally.

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Thanks

Any time frame for when next EAP will be released.

0

Hello Rajnish,

Hopefully, in the end of the next week.

Thanks

Any time frame for when next EAP will be released.

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Is the fix for this issue in build 7757 ?

http://www.jetbrains.net/confluence/display/TW/CalcuttaEAP(build7757)Release+Notes

0

Hello Rajnish,

Unfortunatly this isn't fixed yet.
I cannot reproduce the problem locally. I tried to create a configuration
similar to the one you described and everything works just fine.
However I noticed an oddity in your example of an URL. You wrote

starteam://host:49201/Project 1/View AA/View BB/Source

Not sure if this is a misprint, but a StarTeam URL should not contain multiple
views. It should look like

starteam://host:49201/Project 1/View BB/Source

Could this be the cause?

Is the fix for this issue in build 7757 ?

http://www.jetbrains.net/confluence/display/TW/CalcuttaEAP(build+775
7)ReleaseNotes

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

sorry, that was a misprint. :)

the url definitely looks like:
starteam://host:49201/Project/View/Source

This is not working.

Am not sure what else I can provide in order to reproduce it. I thought you guys already reproduced it (based on your reply on sept 10th.)

Lemme know if I can be any help

thanks

0

Hello Sergey,

I thought I reproduced it. But that was a different bug. Sorry.

Please describe in maximum possible detail the configuration of this view
and its parent view. I mean not their file structure, but rather their properties,
such as whether it's derived or not, has fixed or floating configuration,
and so on...

This information is important for reproducing this situation.

Thank you

sorry, that was a misprint. :)

the url definitely looks like:
starteam://host:49201/Project/View/Source
This is not working.

Am not sure what else I can provide in order to reproduce it. I
thought you guys already reproduced it (based on your reply on sept
10th.)

Lemme know if I can be any help

thanks

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Hi Sergey,

Attached is the zip with 6 snapshots of st root/views and a text file that explains the snapshots.

Lemme know if you need more info

thanks

raji



Attachment(s):
jetbrains_snapshots.zip
0

Hello rajnish,

I reproduced the problem. Your information was very helpful. Thank you.
Now I'm thinking on how to fix it.

Would you please tell me why the view "ActiveReports 6" is derived from a
timed configuration of the view "ActiveReports.Net 3.0"?

Hi Sergey,

Attached is the zip with 6 snapshots of st root/views and a text file
that explains the snapshots.

Lemme know if you need more info

thanks

raji

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Sergey

Am glad that you could reproduce it. :)

We just decided to do it that way. We have other projects that have branches based on label and they do not work either.

thanks

raji

0

Hello Raji,

I've fixed the bug (I hope). You can try the fix in the next EAP, which is
coming this evening (I hope, again).
It would be very helpful if you try the fix and tell me whether your problems
dissapear.

Thank you.

Sergey

Am glad that you could reproduce it. :)

We just decided to do it that way. We have other projects that have
branches based on label and they do not work either.

thanks

raji

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

I will try it and let you know

thanks

0

Sergey

Will this fix be part of v3 EAP or v4 EAP of TeamCity.

we have 3.1.2 installed currently.

I dont think you guys have posted any EAP today. will wait for tomorrow.

thanks

raji

0

Hello Raji,

This will be 4.0 EAP (coming today).
If you don't want to upgade I can send you the patch to 3.1.2.

Sergey

Will this fix be part of v3 EAP or v4 EAP of TeamCity.

we have 3.1.2 installed currently.

I dont think you guys have posted any EAP today. will wait for
tomorrow.

thanks

raji

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Sergey

Can you send the patch to 3.1.2 please?.

we will see if we want to upgrade at a later time.

thanks

raji

0

Hello Raji,

OK. Give me your email address please.

Sergey

Can you send the patch to 3.1.2 please?.

we will see if we want to upgrade at a later time.

thanks

raji

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Hello Rajnish,

I've sent you the patch. Check your mailbox.

rajnish@datadynamics.com

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.