TeamCity agents disconnected after being authorized

I've googled and searched the forums and can't seem to find a reference to this issue.

The default agent on my teamcity server installs and runs fine, no problems at all.

I recently added another windows TC agent on a separate box on our network, which needed to run under a specific user. That worked... Eventually. I fought it an issue for hours, and then after leaving it alone for another couple hours, it seemed to go away. The issue was:

I added the agent, pointed it at the server and started it. The server immediately saw the agent and marked it unauthorized. I authorized the agent. From then on, despite all I tried, the agent remained disconnected. I tried:
Verifying no firewall. (none)
Verifying IP. (Correctly figured out its IP itself, but I even tried specifying.)
Verifying ping both ways.

I also saw nothing untoward in the logs.

However, after a few hours of me working on other items, the agent showed as connected. It has since been running builds exactly as I would expect it to.

Now I'm adding a Mac build agent, and it's exhibiting the same behavior, but I haven't left it alone as long as I did the previous. It's currently showing as disconnected, with no reason listed as to why.

Has anyone seen this? Is there a log I can look at to find out why I would be having this problem?

I'd love to know this, because it's very likely that when we next purchase an additional build agent, it'll be because we have some fire I'm putting out, and waiting a couple hours and hoping for magic isn't how I'd prefer to do it.

Thanks for any help.

2 comments
Comment actions Permalink

And, after not messing with it, the mac build agent showed.

Is this something I'm just not finding in the documentation?

(I'm also perfectly willing to suspect it could be something really slow about our network, but it would have to be transmitting a ton of data to be that slow. Anyone know what the full process of turning on a build agent entails, under the hood?)

0
Comment actions Permalink

Hello Chris,

The first thing a new agent does after connection - it downloads own plugins and update code from the TeamCity server. During such initial auto-upgrade,
agent is shown as disconnected. The upgrade process can take a couple of minutes (depending of networking and cpu/hdd speed).

Unfortunately, this fact isn't highlighted in the documentation enough.

Kind regards,
KIR

0

Please sign in to leave a comment.