TeamCity .NET Add-in has expired

Hi

We are using TeamCity 4.0 EAP (Build 7757) and whenever we start VS we get an error stating that the TeamCity 4.0 plugin for Microsoft VS has expired. The result is that we cannot do any personal builds etc. TeamCity 4.0 doesn't seem to be released yet, so any idea on how to get this working again? I can probably install a later EAP, but that is a lot of effort that I want to only do once v4.0 has been released (which is soon if I understand correctly).

Thanks

Edited by: Carel Lotz on Nov 17, 2008 3:07 PM

4 comments
Comment actions Permalink

(Bump) Any news on this?

Thanks
Carel

0
Comment actions Permalink

Could you please attach a screenshot of the error and plugin's log of the plugin.
To get log of plugin, please do the following:
- close all instances of VS
- open %TEMP%/TeamCity.NET
- remove all files
- start VS
- make it show expiration message
- close VS
- attach all created file in the folder.

Thanks!

0
Comment actions Permalink

Eugene

I followed your steps, deleted the existing log files, restarted VS, got the error message (see attachment), closed VS but alas, no log was created. Any ideas?



Attachment(s):
TeamCity.jpg
0
Comment actions Permalink

Could you please update to newer version of TeamCity EAP. The lifetime of VSPlugin build from EAP you use is limited with 45 days. I have fixed the issue in trunk, so any new TeamCity builds will not contains the issue.
Sorry for inconvenience.

As workaround, could you please update last write time of all vs addin assemblies.

Thanks!

0

Please sign in to leave a comment.