Build failed when new build cleaning up all the compiled files

I setup my TeamCity build using MSBuild as build rrunner. The build only builds sucessfully when I pre-compile the project with visual studio 2005 first and then starts the build without setting the "clean all files before build option" in the version control setting. If I check the clean all files before build option in the version control settings, the build will fail with the following build errors. Looks like the build does not compile the project at all.

Build errors
: Target "Build XDPA Baseline" in project "smartval_msbuild.xml.teamcity.patch.tcprojx" (6s)[10:45:24]: [Target "Build XDPA Baseline" in project "smartval_msbuild.xml.teamcity.patch.tcprojx"] Failure executing test(s). If you assembly is not built using NUnit version 2.4.6.0, then ensure you have redirected assembly bindings. Consult the documentation of the task for more information.[10:45:24]: [Target "Build XDPA Baseline" in project "smartval_msbuild.xml.teamcity.patch.tcprojx"] Could not find a part of the path 'C:\TeamCityBuild\SmartVal\Source\ITP\Xdpa\Constructors\JTag\JTagUnitTest\bin\Debug'. StackTrace: Here is my MSBbuild script: ]]>



Attachment(s):
failbuildlog.txt
2 comments
Comment actions Permalink

That is a bug in TeamCity NUnit test launcer. It should check weather requested .dll files existas.
Could you please check all paths to run NUnit tests with exists on the build angent.
Thanks!

0
Comment actions Permalink

That is a bug in TeamCity NUnit test launcer. It should check weather requested .dll files existas.
Could you please check all paths to run NUnit tests with exists on the build angent.
Thanks!

]]>

0

Please sign in to leave a comment.