Inspections from Maven Based projects...

Hi,

Under TeamCity 4 and running Inspections on a maven based project, I notice in the log:

==> logs/teamcity-build.log <==
[2008-11-29 22:29:12,437] out - Starting up IntelliJ IDEA 8.0 ...done.
[2008-11-29 22:29:20,526] out - Opening project...[INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:20,627] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:21,775] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:21,795] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:22,389] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:22,409] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:22,839] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:22,859] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:24,040] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:24,060] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:24,739] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:24,749] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:24,879] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:24,891] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:24,939] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:24,951] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:25,435] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:25,443] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:25,781] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:25,782] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:26,139] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:26,140] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:26,465] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:26,475] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:26,775] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:26,785] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:27,255] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:27,276] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:28,120] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:28,131] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:28,690] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:28,700] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:29,139] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:29,140] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:29,389] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:29,399] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:29,780] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:29,789] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:30,060] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:30,070] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:30,390] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:30,430] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:30,810] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:30,820] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:31,323] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:31,341] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:31,781] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:31,792] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:32,025] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:32,035] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:32,255] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:32,270] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:32,539] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:32,547] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:29:32,810] out - [INFO] Attempting to resolve a version for plugin: org.apache.felix:maven-bundle-plugin using meta-version: LATEST
[2008-11-29 22:29:32,810] out - [INFO] Using version: 1.4.3 of plugin: org.apache.felix:maven-bundle-plugin
[2008-11-29 22:32:54,384] out - done.
[2008-11-29 22:32:54,464] out - Initializing project...done.
[2008-11-29 22:32:54,593] err - Please configure library 'Maven: org.apache.sling:org.apache.sling.scripting.freemarker:2.0.0-incubator-SNAPSHOT' which is used in module 'integration'
[2008-11-29 22:32:54,594] err - Please configure library 'Maven: smx3.lib:com.springsource.org.apache.commons.codec:1.3.0' which is used in module 'integration'
[2008-11-29 22:32:54,595] err - Please configure library 'Maven: smx3.lib:com.springsource.org.apache.commons.lang:2.4.0' which is used in module 'integration'
[2008-11-29 22:32:54,596] err - Please configure library 'Maven: smx3.lib:spring:2.5.5' which is used in module 'integration'
[2008-11-29 22:32:54,596] err - Please configure library 'Maven: smx3.lib:spring-osgi-annotation:1.1.1' which is used in module 'integration'
[2008-11-29 22:32:54,597] err - Please configure library 'Maven: smx3.lib:spring-osgi-io:1.1.1' which is used in module 'integration'
[2008-11-29 22:32:54,598] err - Please configure library 'Maven: smx3.lib:spring-osgi-core:1.1.1' which is used in module 'integration'
[2008-11-29 22:32:54,598] err - Please configure library 'Maven: smx3.lib:spring-osgi-extender:1.1.1' which is used in module 'integration'

First off - why would I be seeing this repeated check for a new plugin version (and only that one plugin).  And shouldn't the library's already be configured by idea/teamcity?  I don't remember seeing this under TeamCity 3.x.

Please sign in to leave a comment.