Rendering issues when deployed on glassfish (Sun Application Server)

Gday

I have recently started testing TeamCity 4.0 prior to upgrading our existing installation of Teamcity 3.x which is currently running perfectly inside Glassfish.

The installation process is quite simple.

1.Download glassfish-installer-v2ur2-b04-<OS HERE>.jar and install as per there quickstart guide.
2. Set a "JVM Option" to override the default location for teamcity data. In our case we added -Dteamcity.data.path=/data/applications/teamcity.
3. Upload and deploy war file via the web managment interface.
4. Customise the configuration, and move to an external database. in our case enable postgres backend database and CIFS authentication.

Once deployed teamcity functions perfectly performing builds without error. However when going through the interface there seems to be some issues rendering the /profile.html page.

IDE notifier

Directory Listing For /profile/ - Up To /


Filename Size Last Modified
   profile.jsp 3.7 kb Thu, 27 Nov 2008 22:58:39 GMT
   userGeneralSettings.jsp 1.6 kb Thu, 27 Nov 2008 22:58:39 GMT
   userRoles.jsp 0.3 kb Thu, 27 Nov 2008 22:58:39 GMT


The previous list is show in right hand part of the page and the html is pretty much completely broken for that page.

Has anyone else had any issues rendering this page?

Thanks

Mark Wolfe

3 comments
Comment actions Permalink

Hello Mark,

   Could you spot any error in the Glassfish logs?
   Can you probably attach a screenshot how profile page looks like?

   Kind regards,
   KIR

0
Comment actions Permalink

Hello Mark,

  I've found the problem, the fix will be available in TeamCity 4.0.1
  As a workaround, please replace the content of the file WEB-INF/tags/ext/includeExtension.tag with:


<%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core"%>
<%@ attribute name="extension" type="jetbrains.buildServer.web.openapi.PageExtension"%>

<c:if test="${not empty extension}">
  <jsp:include page="${extension.includeUrl}"/>
</c:if>




  Kind regards,
  KIR

0
Comment actions Permalink

The patch you provided resolved the issue for me.

Keep up the good work with Teamcity!

Regards,

Mark Wolfe

0

Please sign in to leave a comment.