SVN checkout not working after upgrading to 4.0 final

Hello,

After upgrading from 4.0 EAP 7757 to 4.0 final TC is not able to check out from our Subversion repository (Subversion 1.5.0, Apache 2.2.9, HTTP, SSPI auth). The error message is "svn: OPTIONS of '/svn-prod/repository/trunk': 403 Forbidden". I've verified that all VCS settings (URL, user, password) are correct. Looking at the Apache HTTP access log it's obvious that TC doesn't send user credentials at all:

172.26.16.143 - "" [02/Dec/2008:21:54:04 +0100] "OPTIONS /svn-prod/repository/trunk HTTP/1.1" 403 227


I've tried other Subversion users (including my own Subversion user) without success. Do you have an idea about what's going on?







Regards, Christian
5 comments
Comment actions Permalink

Hello Cristian,

   We'll try to investigate the problem: TW-6383
   Could you please send us the following information:
   - VCS settings details (screenshot)
   - SVN logs. Please read here how to collects SVN debug logs.

   Please attach details to the issue or send directly to us via e-mail (Send feedback link at the bottom of TeamCity).

  Regards,
  KIR

0
Comment actions Permalink

Hello again,

   Is it possible that we've faced a known issue, as described at:
   Subversion repositories with NTLM Authorization

   Please check this.
   Regards,
   KIR

0
Comment actions Permalink

   Is it possible that we've faced a known issue, as described at:
   Subversion repositories with NTLM Authorization


After adding parameter "-Dsvnkit.http.methods=Basic,NTLM" the TC web server is able to query repository revision and trigger builds - nice.

To get the checkout on the agent running I've added the same parameter to the wrapper.conf configuration. Nevertheless, the agent is still not able to checkout. Looking at the logs, it seems that the agent always prefers NTLM over Basic authentication.

I've attached some logs (agent, web server, Apache), a screen shot and the vcs configuration to the issue.

Regards, Christian

0
Comment actions Permalink

Hello Christian,

   It looks like you placed the -Dsvnkit.http.methods=Basic,NTLM key to the wrong place in wrapper.conf
   You should add the line before

   wrapper.app.parameter.8=jetbrains.buildServer.agent.AgentMain


   and fix the numbers appropriately.

   HTH,
   KIR
0
Comment actions Permalink

Many thanks, moving the line fixed the problem!

Regards, Christian

0

Please sign in to leave a comment.