Wierd problems creating VCS root for ClearCase

We are running ClearCase 7.0.1.1 on Windows XP SP3 and are trying to use TeamCity Version 4.0.1 (build 8171)

We are using ClearCase BASE (as opposed to UCM). 

I am trying to set up TeamCity for the first time at this site (I have done it before at other places but not with ClearCase).

Installation went fine but when I try to create a VCS Root I get the following error

View path: C:\CCShare\snap\klme01_sn_0903\proj

Please select some project directory inside the VOB one. In case your project is in the specified directory you can select any subdirectory and add checkout rule "+:..=>" to this VCS root.

The view at C:\CCShare\snap\klme01_sn_0903 is a snapshot view with a view.dat at that level.

The proj folder is the one containing the Visual Studio solution file.

How do I fix this? The error message is cryptic to me.

I have also tried to set the view path to just C:\CCShare\snap\klme01_sn_0903

I then get the following error

Invalid path: 'C:\CCShare\snap\clme01_sn_0903'; cannot find view root, directory containing 'view.dat' file

This message seems even more absurd since that path is the view root and the only file it contains (except for the proj folder) is the view.dat file.

If I set the view path to C:\CCShare\snap\klme01_sn_0903\proj\csharpcode

Then it connects!

However, this is not the directory that I want, I need the one above that contains the solution file.

So finally I tried to set the view path to C:\CCShare\snap\klme01_sn_0903\proj\csharpcode\..

(Note the two periods at the end, referring to the parent directory)

This seems to work and do what I want. But it was not a very nice workaround.

Please sign in to leave a comment.