FxCop file cannot be deleted

I am trying to set up TeamCity to run FxCop on our code.
I have set up a compilation configuration and a FxCop configuration, the latter being dependent on the former.
I run this setup once and everything works fine, it builds, FxCop runs and generates a nice looking report.
The second time it runs, the compilation configuration fails immediately with the following error:

[09:03:56]: Failed to delete file: C:\BuildAgent\work\PROL\05A1B22A-DE6E-49ae-AA30-DC52A074EF22\fxcop-report.html
[09:03:56]: Failed to clean files from: C:\BuildAgent\work\PROL


This happens whether or not I actually look at the FxCop report through a browser.
The error is correct in the sense that this file is indeed impossible to delete. I have no idea what process is locking it. I have tried running ProcMon and ProcessExplorer from sysinternals, but nothing obvious shows up. The only workaround I have found is to reboot the computer, then I can delete the file.

How do I avoid this error?

Using Windows XP SP3, Team City 4.0.1 (build 8171), FxCop 1.36 beta 2, Visual Studio 2005, Clear Case 7.0.1.1

Thank you,
Klas Mellbourn

3 comments
Comment actions Permalink

Got the same problem

0
Comment actions Permalink

Fixed in 4.x, meanwhile you can run agent on JRE 1.6 >update4, see http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6216226 for more details

0

Please sign in to leave a comment.