Problem about Subversion SSL certificate

Hi,
I use TeamCity Professional Version 4.0.2 (build 8222) and try to configure VCS as below:

    * Type of VCS:                     Subversion(My subversion version is 1.5.5 (r34862))
    * URL:                                 https://XXX.XXX
    * User name/Password:        null (I use SSL and certificate to authenticate.)
    * Default config directory:      selected
    * Configuration directory:       C:\Documents and Settings\caocao\Application Data\Subversion
    * Externals support:              Checkout externals and load external changes 
    * SSH settings:                    null too
    * others:                              default

but "Test connection" says "svn: Authentication required for '<https://XXX.XXX:443>'"

My certificate is pointed out in "C:\Documents and Settings\User\Application Data\Subversion":

ssl-client-cert-file = C:\Documents and Settings\User\Application Data\Subversion\Cert.pfx
ssl-client-cert-password = qwerty

And this is normally works in Eclipse and other CI such as Hudson, but I don't understand, what I should do in TeamCity for using this certificate.


I need help from everyone.
Thanks.

5 comments
Comment actions Permalink

Hello,

  Could you please provide debug information as described at http://url.ie/12kd

  Thanks!
  KIR

0
Comment actions Permalink

Thanks KIR. I just attach it.

Glad to receive your help.

I have a question: Does Teamcity really support SSL and Certificate authentication? Why is so unfriended?



Attachment(s):
logs.rar
0
Comment actions Permalink

Hi KIR,

Have you been here and found something from logs?

I've no idea what I should do.

B/R

0
Comment actions Permalink

Hello,

   Unfortunately, your logs do not contain debug information, and there is no teamcity-svn.log file . Looks like you didn't enable DEBUG logging level, as described in the link.

   Answering your question regarding SSL support - TeamCity uses SVNKit library to access Subversion repositories.
   We didn't test the specific scenario with SSL certificate without username and password, but it should work.

   Please make logging more verbose and send us the results, please also check your settings according to link above.

   Sorry for the problem,
   KIR

0
Comment actions Permalink

Hi KIR,

At first, I should say sorry to you. I made a mistake to attach wrong log file. May be I was too bored to do that.

Now, I attach a new one and I'm sure that it contains the teamcity-svn.log with debug infomation.


I also do my research about what you said just above. I hope it works.

Thank you very much for your help.



Attachment(s):
logs-new.rar
0

Please sign in to leave a comment.