service messages not recognized?

Hi everybody,

Using Teamcity 4.0 I'm trying to create a project statistic.

So I've defined the new statistic in config/main-config.xml like this

  <graph title="Smoke Tests">
   <valueType key="qf1_tests" title="Tests" />
   <valueType key="qf1_warnings" title="Warnings" />
   <valueType key="qf1_errors" title="Errors" />
   <valueType key="qf1_failedtests" title="Failes Tests" />
   <valueType key="qf1_passedtests" title="Passed Tests" />
   <valueType key="qf1_realtime" title="RealTime" />
   <valueType key="qf1_duration" title="Duration" />
  
   <valueType key="qf1_exceptedtests" title="Excepted Tests" />
   <valueType key="qf1_exceptions" title="Exceptions" />
   <valueType key="qf1_executedtests" title="Executed Tests" />
   <valueType key="qf1_expectederrors" title="Exprected Errors" />
   <valueType key="qf1_expectedfailedtests" title="Expected Failed Tests" />
   <valueType key="qf1_nonimpltests" title="Nonimpl. Tests" />
   <valueType key="qf1_skippedtests" title="Skipped Tests" />
   <valueType key="qf1_skippedtestsets" title="Skipped TSets" />
</graph>


and made my build script emit the according '##teamcity' service messages -
but the messages show up in the build-log and no graph is displayed.

[02:11:32]: [echo] ================================
[02:11:32]: [report] echo
[02:11:32]: [echo] Generating report D:\Checkouts\Leonardo/build.tmp/qftest/log/Leonardo1.qrz ...
[02:11:39]: [report] echo
[02:11:39]: [echo] with exceptions
[02:11:39]: [report] groovy
[02:11:39]: [groovy] reading QFTest report info file from D:\Checkouts\Leonardo/build.tmp/qftest/report/report.xml
[02:11:39]: [groovy] Summary: realtime=130939, result=3
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_duration' value='79219']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_errors' value='0']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_exceptedtests' value='3']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_exceptions' value='3']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_executedtests' value='3']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_expectederrors' value='0']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_expectedfailedtests' value='0']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_failedtests' value='0']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_nonimpltests' value='0']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_passedtests' value='0']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_realtime' value='130939']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_skippedtests' value='0']
[02:11:39]: [groovy] ##teamcity[buildStatisticValue key='qf1_skippedtestsets' value='0']
[02:11:40]: [groovy] ##teamcity[buildStatisticValue key='qf1_tests' value='3']
[02:11:40]: [groovy] ##teamcity[buildStatisticValue key='qf1_warnings' value='4']
[02:11:40]: [ant] package
[02:11:40]: [package] echo
[02:11:40]: [echo] ================================


When those messages are shown in the build-log are the recognized as service messages then?
Do the service messages have to thart with the first non-white character???

Thank you very much!
Werner

2 comments
Comment actions Permalink

they started to appear - without any change in config or build script...
thx & byw,
Werner

0
Comment actions Permalink

Please submit a bug report to our tracker if the problem occurs again: http://jetbrains.net/tracker/workspace/TW

0

Please sign in to leave a comment.