Ant echo levels - not used in TC?

Hello,

When I run the following script:

<project default="all">

<target name="all">
<echo message="This is error message." level="error" />
<echo message="This is warning message." />
<echo message="This is warning message." level="warning" />
<echo message="This is info message." level="info" />
<echo message="This is verbose message." level="verbose" />
<echo message="This is debug message." level="debug" />
</target>

</project>



 


I get this on All messages:

[17:01:26]: Starting build process in C:\BuildAgent\work\e8debd57fc005777
[17:01:28]: echo (<1s)
[17:01:28]: [echo] This is error message.
[17:01:28]: echo (<1s)
[17:01:28]: [echo] This is warning message.
[17:01:28]: echo (<1s)
[17:01:28]: [echo] This is warning message.
[17:01:28]: echo (<1s)
[17:01:28]: [echo] This is info message.
[17:01:28]: echo (<1s)
[17:01:28]: [echo] This is verbose message.
[17:01:28]: echo (<1s)
[17:01:28]: [echo] This is debug message.
[17:01:28]: Process exit code: 0
[17:02:09]: Build finished

And I get nothing on Important messages.

Is there a way to use levels on echo to decide which message goes where?

Thanks


7 comments
Comment actions Permalink

I cannot reproduce this problem. What version of Ant do you use? What version of TeamCity server? Can you submit here Ant build runner settings?

0
Comment actions Permalink

TeamCity Enterprise 3.1.1 (build 6828)
Ant is 1.7.1
On "3 Runner: Ant", nothing is populated except for "Path to a build.xml file:" which has "c:\TC\echotest.xml".

I replaced the content of c:\buildagent\plugins\ant with Ant 1.7.1. Is there anything else that I need to do?

Thank you

0
Comment actions Permalink

I would suggest you to upgrade server to version 4.0.2. Probably there were errors related to <echo/> tasks support in previous releases, however I did not find anything similar in our tracker. At least in 4.0.2 version this should work.

0
Comment actions Permalink

One more question. What is c:\buildagent\plugins\ant.jar for?
Do I need to change to that to a newer version somehow?

Thanks

0
Comment actions Permalink

Hello Calvin,

  The support for echo output levels was indeed added only in TeamCity 4.0.

  Regards,
  KIR

0
Comment actions Permalink

Thank you Kirill for the confirmation.

How do I mark this thread as "resolved"? I don't see a star I can click on

0
Comment actions Permalink

I suppose you had to mark the thread as a question to be able to resolve it
Not a problem, anyway

Regards,
KIR

0

Please sign in to leave a comment.