[8804] Invalid ToolsVersion being set

I had this same problem with the previous (8725) build, but had no
answer...

When I copy a project configuration, it builds without problem. If I force
a save of the copied configuration by removing and retyping the sln
configuration name, the new configuration fails to build. I've checked the
generated .sln.teamcity.patch.tcprojx., and it seems to 'forget' to add
the ToolsVersion="3.5" attribute to the ]]> element which makes
MSBuild fail telling me 'error MSB5014: File format version is not
recognized. MSBuild can only read solution files between versions 7.0 and
9.0, inclusive.'.

Any ideas?

Regards,
Pablo

--


The wind is like the air, only pushier.

Pablo Montilla
www.odyssey.com.uy

Please sign in to leave a comment.