Could not get project sources from subversion.

For the past few days the builds were not working correctly with version 4.0, so we upgraded to 4.02, but still getting this same  problem:
Could not get project sources:
Jetbrains.buildServer.vcs.VcsException: Getting sources for checkout rule 'Projects2005=>./Projects2005' failed with erorr: org.tmatesoft.svn.core.SVNException: svn: Processing REPORT request response failed: XML document structures must start and end within the same entity. (/svn/sms/!svn/vcc/default)
svn: REPORT request failed on '/svn/sms/!svn/vcc/default'
jetbrains.buildServer.vcs.VcsException: Getting sources for checkout rule 'Projects2005=>./Projects2005' failed with erorr: org.tmatesoft.svn.core.SVNException: svn: Processing REPORT request response failed: XML document structures must start and end within the same entity. (/svn/sms/!svn/vcc/default)
svn: REPORT request failed on '/svn/sms/!svn/vcc/default'

Setup is:
Subversion latest version
teamcity 4.02
build agent runs on the same machine as teamcity.
we are not using svn externals

Our problem is nearly duplicated here:
http://www.jetbrains.net/devnet/thread/279888

Found this weblink (http://www.nabble.com/REPORT-request-failed-accessing-Sourceforge-Subversion-td14733189.html#a14960933) which mentioned to enable spooling, but I do not know where to put this code? And am not certain if it will fix the problem?
:
IHTTPConnectionFactory factory =   new DefaultHTTPConnectionFactory(null, true, null);
DAVRepositoryFactory.setup(factory);

Any help here is greatly appreciated.



1 comment
Comment actions Permalink

Ok, this issue has been resolved.    We found there was a problem with our subversion repository on Checkout! (Strange we never have had a problem with subversion before.)

The error message returned here "REPORT request response failed: XML document structures must start and end within the same entity."  is quite obscure.
Perhaps if it had said an error was returned from subversion like such "An error was returned from subversion and the error is:", it would have been easier to find...But alas it is now fixed.

0

Please sign in to leave a comment.