LDAP Synchronization - getting errors while synchronizing groups

I have setup LDAP synchronization according to the documents. However i get an error message, that something with my groups synchronization settings is not working.

<!DOCTYPE mapping SYSTEM "ldap-mapping.dtd">
<mapping>
  <!-- Example mapping entry:
  <group-mapping teamcityGroupKey="GROUP" ldapGroupDn="CN=Group,DC=Example,DC=Com"/>
  -->
  <group-mapping teamcityGroupKey="TEAMCITY_ADMINS" ldapGroupDn="CN=teamcityadmins,OU=groups,DC=insomnia-hq,DC=de"/>
  <group-mapping teamcityGroupKey="ALL_USERS_GROUP" ldapGroupDn="CN=teamcity,OU=groups,DC=insomnia-hq,DC=de"/>
</mapping>
ldap-mapping.xml (END)


I simply copied the example entry. However i get the following errors in the log file.

[2009-04-27 22:19:52,450]   INFO -     jetbrains.buildServer.LDAP - ------ Sync with LDAP groups started ------
[2009-04-27 22:19:52,451]   WARN -     jetbrains.buildServer.LDAP - Error on line 2 of document file:/srv/teamcity/data/config/ldap-mapping.xml: Element type "mapping" must be declared.
[2009-04-27 22:19:52,451]   INFO -     jetbrains.buildServer.LDAP - LDAP groups mapping loaded
[2009-04-27 22:19:52,452]   INFO -     jetbrains.buildServer.LDAP - Groups mapping is empty, or not configured. User groups are not synchronized

Any insights in what i might be doing wrong?

Best regards,
Jan

1 comment
Comment actions Permalink

Okay, it was a problem with the ldap-mapping.dtd. For some odd reason it was created with 0 byte filesize, and therefore the XML could not be validated. After deleting the file, it was recreated correctly so now this seems to work. I still got the issues outlined in http://jetbrains.net/devnet/thread/281298, which apply to group synchronization as well.

0

Please sign in to leave a comment.