TeamCity can't connect to build agent on same machine

I upgraded from 3.x to 4.5 today without incident.  However, despite the fact that the agent windows service is running, TeamCity is not able to connect to it, reporting a Ping Failed error message.  I've restarted the build agent and web server multiple times with no benefit.  Given that nothing has changed at the OS level on this machine, and the build agent was working fine for months, I can't see it being a firewall issue but I'll check anything at this point....Any advice?untitled.JPG

4 comments
Comment actions Permalink

Can you attach agent and server logs?

0
Comment actions Permalink

I experienced the same problems. Here's what you can try:

  • Run the build agent service under your user account, that is, not as System level. Change this in the services configuration within windows.
  • Also, try starting the service.start.bat within a console that is running as Administrator.


Probably it was the first point that finally solved it for me.

/Daniel

0
Comment actions Permalink

Here are all logs.  I should mention that I'm running TeamCity/tomcat under SSL using instructions here.  However, when I try to import the cert into the build agent per instructions, I'm getting an error.  I think if I can get the import cert to work, my issue will be resolved.  See below for command output

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.



D:\TeamCity\jre\bin>keytool -importcert -file D:/TeamCity/Conf/TeamCityKeyStore
-keystore D:/TeamCity/jre/lib/security/cacerts
Illegal option:  -importcert

D:\TeamCity\jre\bin>keytool -import -file D:/TeamCity/Conf/TeamCityKeyStore -key
store D:/TeamCity/jre/lib/security/cacerts
Enter keystore password:  changeit
keytool error: java.lang.Exception: Input not an X.509 certificate






Attachment(s):
teamcity-agent.log
logs.zip
0
Comment actions Permalink

Please use keytool from JDK 1.6. TeamCity's jre is 1.5 and keytool of java 1.5 does not support -importcert option. I will update our doceumentation.

0

Please sign in to leave a comment.