Trying to reset password (documentation is incorrect...?)

I'm trying to reset a password in my TeamCity install (4.5.1, just upgraded from the 4.0 EAP). I'm running this command:

\teamcity\jre\bin\java -cp server.jar;utils.jar;hsqldb.jar ChangePassword mark password d:\teamcity\.BuildServer

which I got from the documentation, and I get an error:

Using TeamCity configuration directory path: d:/teamcity/.BuildServer
Exception in thread "main" java.lang.NoClassDefFoundError: jetbrains/buildServer/serverSide/crypt/EncryptUtil
        at ChangePassword.main(ChangePassword.java:1)

I noticed there is no utils.jar in the D:\TeamCity\webapps\ROOT\WEB-INF\lib directory, so I tried the command with util.jar instead, but I got the same error. I'm guessing I'm missing a jar here in the -cp parameter, but I haven't a clue which one I'm missing. Help please?

Mark

3 comments
Comment actions Permalink

Indeed, starting from TeamCity 4.x there should be common-api.jar instead of utils.jar. I updated documentation, thanks.

0
Comment actions Permalink

That was definitely an issue, but there were still other jars missing. This is the command line that finally worked:

\teamcity\jre\bin\java -cp server.jar;common-api.jar;commons-codec-1.3.jar;util.jar;hsqldb.jar ChangePassword administrator password d:\teamcity\.BuildServer

Thanks!

0
Comment actions Permalink

Thanks for your efforts . Docs is re-fixed.

0

Please sign in to leave a comment.