CVS 'Test Connection' hangs

Hi,
I just downloaded TeamCity 4.5 to try it out. I have it installed on windows xp. when I tried to add the VCS configuration and clicked 'Test Connection' the loading image just stays like that forever until I click 'Cancel'. When I click cancel I get a message saying that the responseXML is empty. I can use TortoiseCVS to checkout the module without any problems. Here are the settings that I am using -

Type of VCS: CVS
Module Name: ModuleDirectory/ModuleName
CVS Root: ext - :ext:uname@cvs.server.com:/srv/cvs
Path to external rsh: C:\Program Files\TortoiseCVS\TortoisePlink.exe (Tried with and without this information)
Path to private key: C:\Private Keys\cvsprivatekey.ppk (Tried with and without this information)
(The private key has a password associated but the key already added to pageant)

Can someone please help me figure out what I am doing wrong?
Thanks!

3 comments
Comment actions Permalink

Have you tried to use ssh protocol instead of ext? How did you create your private key/public key?

0
Comment actions Permalink

When I try the ssh protocol I get 'Invalid passphrase (Details: A suitable key format could not be found!). (null)'
Either ext or ssh works fine through tortoisecvs.
The key file was created using putty key generator

0
Comment actions Permalink

After converting the key file to openssh format it works fine - (http://www.jetbrains.net/devnet/thread/146341)
Thanks for your help!

0

Please sign in to leave a comment.