code coverage issue

Hi,

i have a weird behavior of TC when using code coverage. My current parameters for Coverage instrumentation parameters are:

-ix -*Test* -*.jasper

With that definition, i dont get a CodeCoverage Tab in the Test Details. I also tried: -ix -*Test*, -*.jasper

Before i used JASPER Reports, i used:

-ix -*Test*

That worked but now i need to exclude the jasper files, otherwise i am getting an error during emma processing.

Any ideas why i dont get the CodeCoverage with the the settings above (the one with jasper) ?

Thanks.

1 comment
Comment actions Permalink

ups. Misunderstood the working of EMMA. Now i added emma.jar to the compile classpath to that the Jasper Compiler can work with the instrumented classes. Excluding classes makes no sense and if so, i needed to exclude different classes. In fact the classes the report used but i dont want to exclude my domain classes from instrumentation. So adding EMMA*.jar is the best choice.

Marc

0

Please sign in to leave a comment.