svn: Expected FS format between '1' and '3'; found format '4'

Hello,

When trying to create a new VCS root in TeamCity I am getting:

svn: Expected FS format between '1' and '3'; found format '4'

This probably has to do with the latest (new) subversion version I am using as this problem seems related to this post:
http://www.jetbrains.net/devnet/thread/276516

The versions :

* svn, version 1.6.0 (r36650)
   compiled Mar 26 2009, 08:29:37
Then I tried a number of TeamCity versions (uninstall/install)
* TeamCity - The one I had installed already (whichever was the version Dec last year, I think  4.0.1)
* TeamCity Professional Version 4.0.2 (build 8222)
* TeamCity Enterprise Version 4.1 EAP (build 8804) 

It seems like my only option for the time being is to downgrade my svn clients to 1.5? Or is there something else (easier) I can try?

Thank you,
Kind regards,

Hans

11 comments
Comment actions Permalink

It's related to this alright.

FS format 4 indicates that the repository you are accessing has been updated to SVN 1.6.0 layout format internally.

Expected a version between 1 and 3 indicates that you are trying to access it using a client which does not understand SVN 1.6 layout format.

0
Comment actions Permalink

Hello,

  Could you please try accessing your repository not within TeamCity, but from command line client.

  Please use the same protocol and credentials as you use in TeamCity, and please try the access from the machine TeamCity is installed on.

  I suspect that the problem may be not in TeamCity but in your subversion server configuration - when 1.5 binaries are used to access 1.6 repository.

  Kind regards,
  KIR

0
Comment actions Permalink

Hi,

Well, I tried what you asked, expecting the same problem I had before, but the svn connection seems to be working now ...

The only thing I can think of that has changed meanwhile is restarting my machine. I reinstalled/installed without rebooting every single time (slow laptop).

So, no idea what the root cause was (still curious and willing to investigate further if needed) but I can continue now.

Thank you,

Hans

0
Comment actions Permalink

Hi,

I have the same problem with SVN (1.6.1) and TeamCity (4.5.1).
When I use the command line client, everything is working fine.

Thank you for any help in advance,
Timo.

0
Comment actions Permalink

Hi,

   Please try running your svn command from command line client from the TeamCity server.
   Could you please provide some more details on your configuration (checkout mode, SVN settings)
  and the exact error you get.


  Kind regards,
  KIR

0
Comment actions Permalink

Hi,

VCS Root has the following settings using TeamCity 4.5.1:

Type of VCS: Subversion
URL: file:///home/svn/myRep
User name:
Password:
Use default config directory (default settings)

When I press "Test connection", I get the following message:

svn: Expected FS format between '1' and '3'; found format '4'

The repository is located on the same machine as the TeamCity Server.
Subversion has the following version:

svn, version 1.6.1 (r37116)
   compiled May 10 2009, 17:39:00


Using the command line client to checkout the sources is working fine:

svn co file:///home/svn/myRep

Regards,
Timo.

0
Comment actions Permalink

Hello Timo,

  I'm afraid that for file:// access protocol TeamCity cannot handle 1.6 repositories yet.
  You can workaround this problem by enabling svnserve for your repository and access it via svn:// protocol.

  Please also watch issue TW-7676 for 1.6 support.

  Thanks,
  KIR

0
Comment actions Permalink

Hi Kirill,

actually it's not possible to use svnserve in our setup.
But thanks a lot for your help, I will keep an eye on the issue to change it some other day

Regards,
Timo.

0
Comment actions Permalink

Hello Timo,

  The problem is fixed and the fix is about to be released on Monday (unless something bad happens) as a part of TeamCity 4.5.2.

  Regards,
  KIR

0
Comment actions Permalink

Hi Kirill,

the problem is solved and everything is working fine now

thanx for your support,
Timo.

0
Comment actions Permalink

Good news, thanks

0

Please sign in to leave a comment.