Build runner does not run automatically

Hello TC users. I have some problem with my configuration.

I set up new build with parameters:
     1 Checkout sources automatically from SVN
     2 Use build runner through command line

TC checkout sources correctly but after that it does not run my command for shell, and I have to run it manually. What the thing can be?

5 comments
Comment actions Permalink

Hello,

  Please provide the command line runner settings you use. Remember that command parameters should be specified separately from the command itself.

  Please also take a look at buildAgent/logs/teamcity-agent.log and buildAgent/logs/teamcity-build.log

  Regards,
  KIR

0
Comment actions Permalink

We are using simple command line that name is build.sh. It gets no arguments and its task is only run tests. This file is ok and when we Run build by hand it executes. Also I have a look at logs but TC logged only results of runned builds. And no error I saw there. Forgot to note, build runner is placed in checkout directory. It is not Java project or .NET, it is Python.



Attachment(s):
Screenshot-BuildRunner.png
0
Comment actions Permalink

Hello Vitaly,

  Please try to specify /bin/sh as a program executable, and "-c build.sh" as its argument.

  Hope this helps,
  KIR

0
Comment actions Permalink

Hi Kirill

Unfortunately it does not work. I looked at logs and attached them. I actually don't understand what happens there But may be it will clear my problem.

Thanks to you for help.



Attachment(s):
buildAgent-logs - Terminal.png
0
Comment actions Permalink

Hello Vitaly,

   Did you see any build output in the teamcity-build.log file?
   Could you please try create a fake build script which would just echo "something" and  try it with TeamCity?

   Regards,
   KIR

0

Please sign in to leave a comment.