Internal error when running MSBuild task on Vista/2008

Hi there

I was trapped into this problems for days, the build agent running on Vista or Windows 2008
would get the following messages when it use MSBuild runner. But everything is pretty good
if i use Command line runner to run MSbuild script.

I still want MSBuild runner back, could I?

Error message from: TeamCity-Agent.log


[2009-06-25 18:14:15,884]   INFO - impl.runStages.CallRunnerStage - Start actual runner for build 12440 MSBuild
[2009-06-25 18:14:15,884]   INFO - impl.runStages.CallRunnerStage - ----------------------------------------- [ Sandbox::Property Test #8 (buildId = 12440) ] -----------------------------------------
[2009-06-25 18:14:15,900]   INFO - .runner.adapt.BuildProcessImpl - jetbrains.buildServer.RunBuildException: Internal error
jetbrains.buildServer.RunBuildException: Internal error
at jetbrains.buildServer.agent.runner.GenericProgramRunner.run(GenericProgramRunner.java:123)
at jetbrains.buildServer.agent.impl.runner.adapt.BuildProcessImpl$2.run(BuildProcessImpl.java:55)
at java.lang.Thread.run(Thread.java:595)
Caused by: java.io.IOException: The system cannot find the path specified
at java.io.WinNTFileSystem.createFileExclusively(Native Method)
at java.io.File.checkAndCreate(File.java:1345)
at java.io.File.createTempFile(File.java:1434)
at com.intellij.openapi.util.io.FileUtil.doCreateTempFile(FileUtil.java:354)
at com.intellij.openapi.util.io.FileUtil.createTempFile(FileUtil.java:327)
at jetbrains.buildServer.agent.msBuild.MSBuildRunnerBase.buildCommandLine(MSBuildRunnerBase.java:194)
at jetbrains.buildServer.agent.runner.GenericProgramRunner.run(GenericProgramRunner.java:103)
... 2 more
[2009-06-25 18:14:15,900]   INFO - rver.agent.impl.BuildRunAction - jetbrains.buildServer.RunBuildException: Internal error



9 comments
Comment actions Permalink

Hi,

"FileUtil.createTempFile"
makes me wonder if there is not a access right problem when creating files on your disk.

Note that Vista is supported but 2008 not yet.

Olivier.

0
Comment actions Permalink

Hi Olivier

This issue only occurs when the build agent running as a console, if the build agent running as a windows service, it works.

But I need the build agent running as a console that I can run UI tests on the agent.

Thanks
Zhang Ling

0
Comment actions Permalink

Hi Olivier

I have checked the agent, it running on 32bit Windows 2008 english operation system.

Currently we have 6 agents in the build farm, there are
#1. Windows XP SP3 English (32bit)           -- Success
#2. Windows 2003 R2 SP2 English (32bit)   -- Success
#3. Windows Vista SP2 Enghlish (32bit)      -- Failure  (UAC disabled)
#4. Windows Vista SP2 Japanese (32bit)     -- Failure  (UAC disabled)
#5. Windows 2008 SP2 English (32bit)        -- Failure  (UAC disabled)
#6. Windows 7 RC English (32bit)                -- Not tested

Maybe Win7 still have this problem.

Thanks
Zhang Ling

0
Comment actions Permalink

OK, so there's no link with x64 architecture issue.

But as VISTA and 2008 Server are brothers OS, there may be a limitation.
I hope Jetbrains support give you an answer soon, as Vista is a TeamCity supported OS.

Regards,

Olivier.

0
Comment actions Permalink

Hello,

Could you please attach <agent>/conf/buildAgent.properties file and zipped <agent>/logs folder.
Please make sure build agent is able to have access to %TEMP%, <agent>/temp folder. If it was strated
as service it could have created some files that are not accessible now. It is either necessary to give build
agent full perimissions inside it installation folder.

What account do you use to run agent from console?

Have you cleaned any folders while build agent was running?

Thanks!

0
Comment actions Permalink

Hi Eugene

I have did a test was change workDir in BuildAgent.conf from 'D:\' to 'D:\work', the MSBuild runner running in console is very happy.
The 'D:\work' have the same permission with 'D:\' but I don't know why they have differences.

I use a domain account which in local administrators group to run the console.
The administrators have full permission to work directory (both 'D:\' or 'D:\work')

I didn't have any plan to clean the folders during build process.

The attachment is the log files.

Thanks
Zhang Ling



Attachment(s):
Upload.zip
0
Comment actions Permalink

Could you please configure build agent to have temp folder not under work folder. For example: D:\work and D:\temp
Thanks!

0
Comment actions Permalink

Thanks for your help! The issue has sloved.

0

Please sign in to leave a comment.