Teamcity conflicts with previously installed Tomcat

I have installed Teamcity to machine with previously installed Tomcat. First, After Tomcat service restart I've got the problem with TeamCity service - it was stopped. Second, my Tomcat previously used service stop working! Also in some cases TeamCity web interface doesn't work. Even after TeamCity complete uninstallation Tomcat service don't work. Connector port and redirectPort for TeamCity were differ to such ports in Tomcat config. What can be problem with? Maybe I should reconfigure some other settings?

Has anyone such problem (when in one machine both Tomcat and TeamCity are installed)?

5 comments
Comment actions Permalink

Just the tomcat listening ports conflict.
You can modify the teamcity tomcat ports(all ports) in server.xml to distinguish with tomcat installed before.
Have a try.

0
Comment actions Permalink

As I wrote I have modified Connector ports:


TOMCAT CONFIGURATION:


<Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" />



 


TEAMCITY CONFIGURATION:


<Connector  port="8787"                protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8448" />



 



Or some other ports must be modified?

0
Comment actions Permalink

Yes ,you should modify the <Server port="8005" shutdown="SHUTDOWN"> the top line in the server.xml.
you may simplely modify the all the ports presented in the file.

or first you type "netstat -an" to see which port conflict,then you will know which to modify.

0
Comment actions Permalink

Thanks! It seems that it works.

But why TeamCity install has no warnings or even automatic actions to prevent user from such port conflicts? This question is for TeamCity developers team. I meaned exactly this setting: "<Server port="8005" shutdown="SHUTDOWN">" (connector port can be changed during installation process).

0
Comment actions Permalink

Maybe the teamcity developer want to keep the app simple,it is just a webapp.

0

Please sign in to leave a comment.