Running TeamCity on Windows 7

Hi,

I have just installed TeamCity 4.5.4 Build 9071 on Windows 7 Ultimate and in the Event Log I am getting an error message stating that the build service is setup to "Interact with the desktop" although the system does has not been setup to allow this. I can access the local TeamCity website, but I've not yet setup a build. This was not an issue when running in Vista, so I have a few questions:

1) How is the "Interact with the desktop" option used by TeamCity?
2) Could I "uncheck" this option on the Build Agent service?
3) If I simply ignore the error will TeamCity still function as normal? If the "interact with the desktop" option must be enabled how can I configure Windows 7 to allow this option on services?

Kind Regards


Sid

4 comments
Comment actions Permalink

Interact with desktop option is only required if your build started by TeamCity agent needs to interact with windows desktop. If not you can safely turn this option off.

0
Comment actions Permalink

In what situations would the agent need to interact with the desktop? I am planning to either have builds start automatically or start builds manually through the local web site.

Regards

Sid

0
Comment actions Permalink

Agent does not need such interaction at all, but builds starting by agent sometimes do need to show some windows or dialogs. Also some testing frameworks need to interact with browsers.

0
Comment actions Permalink

From what you've said I don't think I need this option on. Thanks Pavel for your help.

0

Please sign in to leave a comment.