svn+ssh with private key - Authentication required

I'm tring to set up a VCS root in TeamCity version 4.5.4 (build 9071) to use svn+ssh with private key, but it gives me an exception when I Test the connection: "svn: Authentication required for 'svn+ssh://ip.to.server'". I have set up other roots that don't require a key, and they work fine. The problematic repository also works fine with TortousSVN + putty.

I have noticed other people having this problem. The solution in http://jetbrains.net/tracker/issue/TW-7520 was to export the private key using openSSH and use that. I tried, but it did not help me .

I also tried to manually edit the wrapper.conf in the manner explained in this blog post, with no effect.

I'm specifying SVN Connection Settings: Url, User name, password, as well as SSH settings: private key file, key file password, and ssh port.

I can't find any teamcity-svn.log. Dump from teamcity-vcs.log (some "private data" changed):


[2009-08-10 11:12:33,408]   WARN [hanges loader 5] -      jetbrains.buildServer.VCS - Error while loading vcs version for root 'Gateway2', id=3: org.tmatesoft.svn.core.SVNAuthenticationException: svn: Authentication required for 'svn+ssh://ip.to.server'
[2009-08-10 11:12:33,409]   WARN [hanges loader 5] -      jetbrains.buildServer.VCS - Error while loading changes for root svn: svn+ssh://ip.to.server/something/somthing/Gateway2 {id=3}, cause: org.tmatesoft.svn.core.SVNAuthenticationException: svn: Authentication required for 'svn+ssh://ip.to.server'
[2009-08-10 11:13:01,881]   WARN [    http-8080-1] -      jetbrains.buildServer.VCS - Error occurred in test connection
jetbrains.buildServer.vcs.VcsException: svn: Authentication required for 'svn+ssh://ip.to.server'
at jetbrains.buildServer.buildTriggers.vcs.svn.SvnSupport.testConnection(SvnSupport.java:253)
at jetbrains.buildServer.controllers.admin.projects.EditVcsRootsController.doPost(EditVcsRootsController.java:174)
at jetbrains.buildServer.controllers.BaseFormXmlController$1.handleRequest(BaseFormXmlController.java:37)
at jetbrains.buildServer.controllers.AjaxRequestProcessor.processRequest(AjaxRequestProcessor.java:29)
at jetbrains.buildServer.controllers.BaseFormXmlController.doHandle(BaseFormXmlController.java:35)
at jetbrains.buildServer.controllers.BaseController.handleRequestInternal(BaseController.java:60)
at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)
at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:48)
at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:875)
at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:809)
at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:523)
at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:463)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at jetbrains.spring.web.TeamCityDispatcherServlet.service(TeamCityDispatcherServlet.java:3)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at jetbrains.buildServer.web.ResponseFragmentFilter.doFilter(ResponseFragmentFilter.java:18)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
at java.lang.Thread.run(Thread.java:595)



 


TeamCity is a brilliant product, and I really want to use it with my team. Please advice!

2 comments
Comment actions Permalink

Hello,

  I'm sorry for delay with the answer.

  Please configure Teamcity to use RSA key produced by OpenSSH (as described in the issue) and enable Subversion debug logging.

  I hope this would give a clue what's wrong with your configuration.

  Kind regards,
  KIR

0
Comment actions Permalink

We worked around this issue by opening up to use non-ssh communication between svn server and TeamCity server, so for now I don't need a solution. Thanks anyway. Great product!

0

Please sign in to leave a comment.