Build Agent won't run

Our build agent won't run at the moment - it's not picking up new builds.

On the teamcity Agent's page - it is connected but when you try to view it - it shows the error:

Error message: Error reading 'cpuBenchmarkIndex' on type jetbrains.buildServer.serverSide.impl.auth.SecuredBuildAgent

Lower down:

Caused by: java.lang.NumberFormatException: For input string: "5154639175"

When reading the teamcity-agent.log file - The first part starts:


[2009-08-24 19:07:47,859]   INFO -    jetbrains.buildServer.AGENT - Starting TeamCity agent
[2009-08-24 19:07:49,656]   INFO -    jetbrains.buildServer.AGENT - Calculating plugins signature for possible upgrade
[2009-08-24 19:07:50,797]   INFO -    jetbrains.buildServer.AGENT - Build Agent version: 9071, plugins signature: 1a65ed2d
[2009-08-24 19:07:50,875]   WARN -    jetbrains.buildServer.AGENT - Calculating CPU benchmark index...
[2009-08-24 19:08:05,624]   WARN -    jetbrains.buildServer.AGENT - CPU benchmark index is set to 5154639175
[2009-08-24 19:08:06,343]   INFO -    jetbrains.buildServer.AGENT - Calculating plugins signature for possible upgrade
[2009-08-24 19:08:07,421]   INFO -    jetbrains.buildServer.AGENT - Build Agent version: 9071, plugins signature: 1a65ed2d

I'm guessing that the CPU benchmark index is too high to be parsed into a number or something similar to that.

We've upgraded to 4.5.4 and we've reinstalled teamcity / a brand new separate build agent.  Rebooted the computer and all that.

We are running on a VM (using xVM - virtual box) - it has tons of CPU / memory available.
It was working fine and has been working fine for a long time; but stopped working recently (on Friday I believe).




10 comments
Comment actions Permalink

Please submit a bug report with agent logs attached.

As for workaround try to disable CPU benchmark calculation by providing system property teamcity.agent.cpuBenchmark.enabled=false
If you start agent via the service, take a look at <agent inst dir>/launcher/conf/wrapper.conf file - you should provide this property there
Otherwise you'll need to set environment variable TEAMCITY_AGENT_OPTS=-Dteamcity.agent.cpuBenchmark.enabled=false

0
Comment actions Permalink

I've tried setting the environment variable and the service property.

I'm still getting that error and the build isn't running.

I've submitted a bug http://jetbrains.net/tracker/issue/TW-9288

0
Comment actions Permalink

So how do you start your agent?

0
Comment actions Permalink

windows service

0
Comment actions Permalink

Then you need to change wrapper.conf, could you please attach the changed conf file here?

0
Comment actions Permalink

Attached

I added the property to the bottom of the file.

Cheers,



Attachment(s):
wrapper.conf
0
Comment actions Permalink

Attached is a file which should work in your case. Unfortunately wrapper.conf is not just a property file, it has some structure and JVM arguments should be placed at the special section.



Attachment(s):
wrapper.conf
0
Comment actions Permalink

Thanks - we are up and running again now.

0
Comment actions Permalink

Colin, is it possible to start agent under the virtual machine with one CPU core only and check whether CPU benchmark is calculated correctly? I suspect this issue can be caused by incorrect time calculation on systems with multi core processors.

0
Comment actions Permalink

As far as I know - there is no way to manage the CPU on virtualbox.  I believe it's a requested feature.

As far as the VM is concerned there is only one CPU available to it - but the actual physical box underneath is definitely multi-core.

0

Please sign in to leave a comment.