ASPNETCOMPILER : error 1003: The directory 'C:\TeamCity\buildAgent\work\WebSite1\' doesn't exist.

I just installed VisualSVN with TeamCity.

I uploaded a simple asp.net app created in visual studio 2008

1)I am using a BuildRunner of 'sln2008'
2)Solution path = 'WebSite1.sln'

Yet I keep on getting this error.



 


ASPNETCOMPILER : error 1003: The directory 'C:\TeamCity\buildAgent\work\WebSite1\' doesn't exist.


[08:07:02]: Project "WebSite1.sln.teamcity.patch.tcprojx" (Build_TeamCity_generated_5890878f15414d4d8c0c9781bdc41ef2 target(s)):
[08:07:02]: [Project "WebSite1.sln.teamcity.patch.tcprojx" (Build_TeamCity_generated_5890878f15414d4d8c0c9781bdc41ef2 target(s)):] Project "WebSite1.sln" (Rebuild target(s)):
[08:07:02]: [Project "WebSite1.sln" (Rebuild target(s)):] ASPNETCOMPILER error 1003: The directory 'C:\TeamCity\buildAgent\work\WebSite1\' doesn't exist.
[08:07:02]: sln2008 output: c:\TeamCity\buildAgent\bin\..\plugins\dotnetPlugin\bin\JetBrains.BuildServer.MsBuildBootstrap.exe @xml C:\TeamCity\buildAgent\temp\cache\msbuild22670.teamcity.bootstrap.properties TeamCity MSBuild bootstrap v4.5 Copyright (C) JetBrains s.r.o. Start MSBuild... 'C:\Windows\Microsoft.NET\Framework\v3.5\MSBuild.exe' '@"C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln.teamcity.msbuild.tcargs" "C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln.teamcity.patch.tcprojx"' working dir = 'C:\TeamCity\buildAgent\work\bdba729f48713c9' Microsoft (R) Build Engine Version 3.5.30729.4926 [Microsoft .NET Framework, Version 2.0.50727.4927] Copyright (C) Microsoft Corporation 2007. All rights reserved.  Build started 8/28/2009 8:07:02 AM. Project "C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln.teamcity.patch.tcprojx" on node 0 (Build_TeamCity_generated_5890878f15414d4d8c0c9781bdc41ef2 target(s)). Project "C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln.teamcity.patch.tcprojx" (1) is building "C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln" (2) on node 0 (Rebuild target(s)).   Building solution configuration "Release|Any CPU". ASPNETCOMPILER : error 1003: The directory 'C:\TeamCity\buildAgent\work\WebSite1\' doesn't exist. Done Building Project "C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln" (Rebuild target(s)) -- FAILED. Done Building Project "C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln.teamcity.patch.tcprojx" (Build_TeamCity_generated_5890878f15414d4d8c0c9781bdc41ef2 target(s)) -- FAILED.  Build FAILED.  "C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln.teamcity.patch.tcprojx" (Build_TeamCity_generated_5890878f15414d4d8c0c9781bdc41ef2 target) (1) -> "C:\TeamCity\buildAgent\work\bdba729f48713c9\WebSite1.sln" (Rebuild target) (2) -> (WebSite1:Rebuild target) ->    ASPNETCOMPILER : error 1003: The directory 'C:\TeamCity\buildAgent\work\WebSite1\' doesn't exist.      0 Warning(s)     1 Error(s)  Time Elapsed 00:00:00.18


1 comment
Comment actions Permalink

Hi!

The work space for the agent has been set to:
C:\TeamCity\buildAgent\work\bdba729f48713c9

ASP compiler is looking for:
C:\TeamCity\buildAgent\work\WebSite1\

So, I think that you have a path problem within your solution (too much ".." maybe)

Regards,

Olivier.

0

Please sign in to leave a comment.