Failed to create build checkout directory

Greetings,

I am new to TeamCity and I am trying to setup and build my first project.  I have downloaded and configured TeamCity Professional 4.5.5 build 9103.  I am using subversion as my VCS.  I thought I had everything configured correctly, but when I start the build I get a "Failed to create build checkout directory" error after all the files have been extracted from svn.

[07:54:37]: Checking for changes
[07:54:39]: Clearing temporary directory: C:\Programs\TeamCity\buildAgent\temp\buildTmp
[07:54:40]: Checkout directory: C:\Work\WIW\1.9.1.0_Integration
[07:54:40]: Updating sources (6m:46s)
[07:54:40]: [Updating sources] Updating project sources (6m:45s)
[07:54:40]: [Updating project sources] Clean sources required
[07:54:40]: [Updating project sources] Cleaning C:\Work\WIW\1.9.1.0_Integration
[07:54:47]: [Updating project sources] Excalibur WIW 1.9.1 Collector; revision: 37176_2009/10/23 07:54:38 -0700
[08:01:26]: Failed to create build checkout directory at C:\Work\WIW\1.9.1.0_Integration\svn:\subversionserver.domain.com\sub1\sub2\branches\1.9.1.0\collector\webapp
[08:01:26]: Build finished
My VCS configuration is:
VCS checkout mode: Automatically on agent
checkout directory: C:/Work/WIW/1.9.1.0_Integration
Clean all files before build: unchecked
VCS labeling mode: Do not label
Choose VCS roots to label: unchecked
VCS Root:
Type of VCS: Subversion
URL: svn://subverserversion.domain.com/sub1/sub2/branches/1.9.1.0/collector/webapp
Username: valid
Password: valid
Default config directory: checked
Configuration Directory: C:\Documents and Settings\Default user\Application Data\Subversion
Externals Support: Full support
SSH Settings: Empty
Labeling Rules: trunk=>tags
Checking interval: use global server settings (60 seconds)
Checkout using subversion from either commandline or gui has no issues, just the TeamCity checkout.  I'm not sure where to look to fix this one.
Thanks in advance,
Ernie
3 comments
Comment actions Permalink

Ernie,


Do you set checkout rules for this build configuration?

0
Comment actions Permalink

Hello Ernest,

  I'm sorry for delay with the answer.
  I suppose this is a kind of misconfiguration.

  Please check that you left field "working directory" blank in your build runner configuration, I suppose you placed subversion url into it.

  If this is not the case, please attach screenshots of your configuration screens, namely, VCS root configuration, VCS settings page for build configuration (step2) and build runner configuration (step 3).

  Kind regards,
  KIR

0
Comment actions Permalink

KIR,

Thank you for the response.  You are absolutely correct.  I had mistakenly pasted the SVN URL into the working directory.

I feel pretty stupid about missing that one.  Everything is up and going now.

Thanks for taking the time to put me straight.

Ernie

0

Please sign in to leave a comment.